HDOJ 1709-The Balance【模拟】

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7241    Accepted Submission(s): 2985


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
 

Source
 解题思路;
主要是一个天平有多个砝码问可以称出的重量,天平左右两边都可以放砝码。暴力就好,随便爆。
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<algorithm>
using namespace std;
int n;
int num[30000];
int ans[30000];
int wc[30000];
int pp[30000];

int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(ans,0,sizeof(ans));
		memset(pp,0,sizeof(pp));
		int i,j;
		int sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&num[i]);
			sum+=num[i];
		}
		for(i=0;i<n;i++)
		{
			for(j=1;j<=sum;j++)
			{
				if(ans[j]) 
				{
					pp[abs(j+num[i])]=1;
					pp[abs(j-num[i])]=1;
				}
			}
			for(j=1;j<=sum;j++)
			{
				if(ans[j]==0&&pp[j]==1) 
				{
					ans[j]=pp[j];
				}
			}
			ans[num[i]]=1;
			memset(pp,0,sizeof(pp));
		}
		int nn;
		nn=0;
		for(int k=1;k<=sum;k++)
		{
			if(!ans[k])
			{
				wc[nn++]=k;
			}
		}
		printf("%d\n",nn);
		for(int k=0;k<nn;k++)
		{
			if(k==0)
			printf("%d",wc[k]);
			else
			printf(" %d",wc[k]);
		}
		if(nn!=0)
		printf("\n");
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值