UVA 题目10617 - Again Palindrome(区间DP)

A palindorme is a sequence of one or more characters that reads the same from the left as it does from
the right. For example, Z, TOT and MADAM are palindromes, but ADAM is not.
Given a sequence S of N capital latin letters. How many ways can one score out a few symbols
(maybe 0) that the rest of sequence become a palidrome. Varints that are only different by an order of
scoring out should be considered the same.
Input
The input file contains several test cases (less than 15). The first line contains an integer T that
indicates how many test cases are to follow.
Each of the T lines contains a sequence S (1 ≤ N ≤ 60). So actually each of these lines is a test
case.
Output
For each test case output in a single line an integer — the number of ways.
Sample Input
3
BAOBAB
AAAA
ABA
Sample Output
22
15

5

题目大意:给一个字符串,问去掉其中几个字符变成回文串,问有多少种去法

思路:多少种去法,实际上就是问这个串里边有多少个回文串,编程之美资格赛的时候做个一个问一个串里边有多少个回文串的,感觉应该问的就是这个,提交,,就过了

ac代码

16449058 825 Walking on the Safe Side Accepted C++ 0.006 2015-11-17 08:21:59

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define LL long long
using namespace std;
long long dp[1010][1010];
char str[1005];
int main()
{
	int t,c=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",str);
		int i,len=strlen(str),j;
		for(i=0;i<len;i++)
		{
			dp[i][i]=1;
		}
		for(i=1;i<len;i++)
		{
			for(j=i-1;j>=0;j--)
			{
				dp[j][i]=(dp[j+1][i]+dp[j][i-1]-dp[j+1][i-1]);
				if(str[i]==str[j])
				{
					dp[j][i]+=dp[j+1][i-1]+1;
				}
			}
		}
		printf("%lld\n",dp[0][len-1]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值