UVa 11151 - Longest Palindrome 字符串dp

Write a program to determine the length of the longest palindrome you can get from a string.

Input and Output

The first line of input contains an integer T (≤ 60). Each of the next T lines is a string, whose length is always less than 1000.

For ≥90% of the test cases, string length ≤ 255.

For each input string, your program should print the length of the longest palindrome you can get by removing zero or more characters from it.

Sample Input

2
ADAM
MADAM

Sample Output

3
5


Problemsetter: Raymond Chun
---------------

听说有空串,所以必须用gets()

---------------

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

char s[1111];
int f[1111][1111];
int n;

int dfs(int l,int r)
{
    if (f[l][r]!=-1) return f[l][r];
    if (r-l<1) return 0;
    int ret=0;
    if (s[l]==s[r])
    {
        ret=dfs(l+1,r-1);
    }
    else
    {
        ret=min( dfs(l+1,r), dfs(l,r-1) )+1;
    }
    f[l][r]=ret;
    return ret;
}

int main()
{
    int T;
    scanf("%d",&T);
    getchar();
    while (T--)
    {
        memset(f,-1,sizeof(f));
        //scanf("%s",s+1);
        gets(s+1);
        n=strlen(s+1);
        int ans=dfs(1,n);
        printf("%d\n",n-ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值