Sorting It All Out(POJ--1094

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

题意:多组输入,每组输入n和m(n=0&&m=0时程序结束),输入m行两个字母的大小,根据这m行来判断26个字母前n个的排序,如果能排除这n个字母的顺序则输出“Sorted sequence determined after xxx relations: yyy...y. ”;如果不能确定则输出“Sorted sequence cannot be determined. ”;如果排序出现矛盾则输出“Inconsistency found after xxx relations. ”。
注意:只要出现了结果则不用再判断后边所输入的根据

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#define INF 0x3f3f3f3f
using namespace std;
int n,m,mmap[50][50],in[50],inn[50];
int topo(int op)
{
    int f=1,i,j,k;                      //标记f=1即假设到目前为止能正确排序
    for(i=0; i<n; i++)              //把每一点的入度数存到inn这个数组里,每调用一次该函数就更新一遍inn数组
        inn[i]=in[i];
    for(i=0; i<n; i++)
    {
        k=-1;
        for(j=0; j<n; j++)
        {
            if(!inn[j])
            {
                if(k!=-1)
                    f=0;
                k=j;
            }
        }
        if(k==-1)return -1;      //如果k=-1就说明到目前为止字母排序已成环
        if(op)              
            putchar('A'+k);        //按顺序输出字母
        inn[k]--;                        //入度数减1
        for(j=0; j<n; j++)          //只要是与k相连的点入度数都减去与其相连的边数
            inn[j]-=mmap[k][j];
    }
    if(op)
        puts(".");
    return f;
}
int main()
{
    //freopen("lalala.text","r",stdin);
    int f,x,a,b,i;
    char st[5];
    while(~scanf("%d %d",&n,&m)&&n&&m)
    {
        memset(mmap,0,sizeof(mmap));
        memset(in,0,sizeof(in));        //记录每点的入度数
        f=0;                                         //标记f=0即假设该排序不能确定这n个字母的顺序
        for(i=1; i<=m; i++)
        {
            scanf("%s",st);
            a=st[0]-'A';
            b=st[2]-'A';
            if(f)continue;                    //如果已经知道了结果则后边的根据不需再进行判断
            mmap[a][b]++;
            in[b]++;
            f=topo(0);
            x=i;
        }
        if(!f)
            printf("Sorted sequence cannot be determined.\n");
        else if(f==-1)
            printf("Inconsistency found after %d relations.\n",x);
        else
        {
            printf("Sorted sequence determined after %d relations: ",x);
            topo(1);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值