G - Sorting It All Out POJ - 1094

G - Sorting It All Out

 POJ - 1094 

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意:给N个大写字母,m个关系,要你判断能不能唯一确定字母的顺序或出现矛盾;

开始一直wa看别人的代码跟自己的又没什么不同,其实是忘了某些细节问题。。。以后先别急着否定自己。。。

#include<iostream>
#include<cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>

using namespace std;
const int N =  77;
const int M = 100007;

char a[M], c[M], b, s[N];
int head[N], deg[N], deg_[N], en, flag;

struct Edge{
	int v, to;
}edge[M];

void addedge(int u, int v) {
	edge[en].v = v;
	edge[en].to = head[u];
	head[u] = en++;
}

void tuopupaixu(int n) {
	
	memcpy(deg, deg_, sizeof(deg_)); //开始忘了每次拓扑之后会改变度数。。 
	queue<int> q;
	for (int i = 0; i < n; ++i) {
		if (deg[i] == 0) {
			q.push(i);
			if (q.size() > 1) {
				flag = -1;
			}
		}
	}
	int count = n, k = 0;
	while (!q.empty()) {
		if (q.size() > 1) {
			flag = -1;
		}
		int now = q.front(); q.pop();
		s[k++] = now + 'A';
		--count;
		for (int i = head[now]; ~i; i = edge[i].to) {
			int v = edge[i].v;
			if (--deg[v] == 0) {
				q.push(v);
			}
		}
	}
	s[k] = '\0';
	for (int i = 0; i < n; ++i) {
		if (deg[i] > 0) {
			flag = 1;
			return;
		}
	}
	if (count > 0) {
		flag = -1;
	}

}

int main() {
	int n, m;
	while (~scanf ("%d %d", &n, &m) && (n+m)) {
		memset(deg_, 0, sizeof(deg_));
		memset(head, -1, sizeof(head));
		for (int i = 1; i <= m; ++i) {
			scanf (" %c%c%c", &a[i], &b, &c[i]);
		}
        flag = 0, en = 0; 
		for (int i = 1; i <= m; ++i) {
			//printf ("debug: %d %d\n", a[i] - 'A', c[i] - 'A');
			addedge(a[i]-'A', c[i]-'A');
			++deg_[c[i] - 'A'];
			flag = 0;
			tuopupaixu(n);
			if (flag == 1) {
				printf ("Inconsistency found after %d relations.\n", i);
				break;
			} else if (!flag){
				printf ("Sorted sequence determined after %d relations: %s.\n", i, s); 
				break;
			}
		}	
		if (flag == -1) {
			puts ("Sorted sequence cannot be determined.");
		}
	}
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值