CSU-ACM2017暑期训练7-模拟&&贪心 A - Radar Installation POJ - 1328

题目:

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output           Case 1: 2           Case 2: 1


题意:x轴以上为海洋,x轴及以下为陆地,海洋中有若干个小岛,现想要侦测到他们,给你一种雷达的检测半径,雷达只能放在陆地上,问最少需要多少个雷达能覆盖全所有的小岛。

思路:显然雷达全放在x轴上是离海洋最近的,对于每一个小岛,都有一个在x轴上放置雷达能覆盖到他的区间,求出这个区间的两端,然后贪心求解即可,具体看代码。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 1000000000;
const int maxn = 100;
int n,d;
int ok,no=0;

struct Island
{
    double l,r;
}island[1111];

bool cmp(Island a,Island b)
{
    return a.l<b.l;
}


int main()
{
    while(scanf("%d%d",&n,&d)!=EOF)
    {
        if(n==0&&d==0)
            break;
        ok=1;
        for(int i=0;i<n;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            island[i].l=(double)a-sqrt((double)d*d-b*b);
            island[i].r=(double)a+sqrt((double)d*d-b*b);
            if(b>d)
                ok=0;
        }
        if(!ok)
        {
            printf("Case %d: -1\n",++no);
            continue;
        }
        sort(island,island+n,cmp);
        int ans=1;
        double radar_x=island[0].r;
        for(int i=1;i<n;i++)
        {
            if(radar_x>island[i].r)
            {
               radar_x=island[i].r;
            }
            else if(radar_x<island[i].l)
            {
                radar_x=island[i].r;
                ans++;
            }

        }
        printf("Case %d: %d\n",++no,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值