Frequent values

Frequent values
Description
You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.
Input
The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the query. 


The last test case is followed by a line containing a single 0.
Output
For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.
Sample Input
10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0
Sample Output
1
4
3
Hint

A naive algorithm may not run in time!

首先给定一个非降序的数列,然后进行查询操作,问范围[a,b]内出现频率最高的数字出现了多少次。

因为通过巧妙的转换,能使它成为一个RMQ问题。

num[i]是原数列,num2[i]是转换后的数列,num2[i]代表与num[i]相同的左边的节点数(包括自己),例如,

(-1 -1 1 1 1 1 3 10 10 10)==>(1 2 1 2 3 4 1 1 2 3)。

这时候因为一个数字出现的频率已经直接出现在num2[i]数列中,我们就可以对num2[i]使用RMQ算法了。不过因为相同的连续的数可能被切成了两段,所以在边界上需要特殊处理。我们把查询范围[a,b]内的数分为二段,第一段为:num[a] ~num[i],其中num[a] > 1,num[i] != 1,num[a] <num[j] <...<num[i]。第二段为num[i+1]...num[b],此段可以用RMQ.。

代码如下:

#include "stdio.h"
#include "math.h"
#define max(a,b) (a > b ? a : b)
#define MAXN 100000
int num[MAXN];
int num2[MAXN];
int dp[MAXN][20];
void create (int n) {
	int i,j,t;
	for (i = 1;i <= n;i++) {
		dp[i][0] = num2[i];		
	}
	t = log(n) / log(2.0);
	for (j = 1;j <= t;j++) {
		for (i = 1;i + (1 << j) - 1 <= n;i++) {
				dp[i][j] = max(dp[i][j-1],dp[i + (1 << (j-1))][j-1]);
		}
	}
}


int getMax (int a,int b) {
	int k = (int)(log(b - a + 1.0) / log(2.0));
	return max (dp[a][k],dp[b-(1<< k) + 1][k]);
}
int query (int a,int b) {
	if (num[a] == num[b]) {
		return b - a + 1;
	}else {
		int left,_a;
		int i = a;
		while (num2[i] != 1) {
			i++;	
		}
		_a = i;
		if (i == a) {
			left = 0;
		}else {
			left = num2[i-1] - num2[a] + 1;
		}
		return max(left,getMax(_a,b));
	}	
}

void print (int n,const int *array) {
	int i;
	for (i = 1;i <= n;i++) {
		printf ("%4d ",array[i]);
	}
	printf ("\n");
}

int main () {
	int n,q,i,j,a,b;
	int t;
	while (scanf ("%d",&n), n != 0) {
		scanf ("%d",&q);
		num[0] = 1;
		num2[0] = 0;
		for (i = 1;i <= n;i++) {
			scanf ("%d",&num[i]);
		}
		//print (n,num);
		for (i = 1;i <= n;i++) {
			if (num[i] == num[i-1]) {
				num2[i] = num2[i-1] + 1;
			}else {
				num2[i] = 1;
			}
		}
		//print (n,num2);
		create(n);
		for (i = 1;i <= q;i++) {
			scanf ("%d%d",&a,&b);
			t = query (a,b);
			printf("%d\n",t);
		}
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值