POJ - 3368 Frequent values(线段树区间合并求区间内最长连续子串的长度模板题)

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

代码:

#include <cstdio>
#include <algorithm>

using namespace std;

const int MAXN = 100005;

int board[MAXN];

struct T{
	int l,r,maxx,s;
}Tree[MAXN*4];

void Up(int temp,int l,int r){
	int m = l + (r-l)/2;
	
	if(Tree[temp<<1].l == Tree[temp<<1].s && board[m] == board[m+1]){
		Tree[temp].l = Tree[temp<<1].l + Tree[temp<<1|1].l;	
	}
	else Tree[temp].l = Tree[temp<<1].l;
	if(Tree[temp<<1|1].r == Tree[temp<<1|1].s && board[m] == board[m+1]){
		Tree[temp].r = Tree[temp<<1|1].r + Tree[temp<<1].r;	
	}
	else Tree[temp].r = Tree[temp<<1|1].r;
	
	if(board[m] == board[m+1]){
		Tree[temp].maxx = Tree[temp<<1].r + Tree[temp<<1|1].l;
	}
	else {
		Tree[temp].maxx = 0;
	}
	Tree[temp].maxx = max(max(Tree[temp<<1].maxx,Tree[temp<<1|1].maxx),Tree[temp].maxx);
}

void Build(int temp,int l,int r){
	Tree[temp].s = r - l + 1;
	if(l == r){
		Tree[temp].l = Tree[temp].r = Tree[temp].maxx = 1;
		return ;
	}
	int m = l + (r-l)/2;
	Build(temp<<1,l,m);
	Build(temp<<1|1,m+1,r);
	
	Up(temp,l,r);
}

int Query(int temp,int l,int r,int ql,int qr){//[ql,qr]闭区间 
	if(l==ql && r==qr){
		return Tree[temp].maxx;
	} 
	int m = l + (r-l)/2;
	if(qr <= m) return Query(temp<<1,l,m,ql,qr);
    else if(ql > m) return Query(temp<<1|1,m+1,r,ql,qr);
    else
    {
        int a1 = Query(temp<<1,l,m,ql,m);
        int a2 = Query(temp<<1|1,m+1,r,m+1,qr);
        int a3 = 0;
        if(board[m] == board[m+1]) 
        {
            a3 = min(Tree[temp<<1].r,m-ql+1) + min(Tree[temp<<1|1].l,qr-m);
        }
        return max(max(a1,a2),a3);
    }
	
}

int main(){
	
	int n,q;
	while(scanf("%d",&n) && n){
		scanf("%d",&q);
		for(int i=1 ; i<=n ; ++i)scanf("%d",&board[i]);
		Build(1,1,n);
		int ql,qr;
		while(q--){
			scanf("%d %d",&ql,&qr);
			printf("%d\n",Query(1,1,n,ql,qr));
		}
	}
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值