poj 2155 Matrix(树状数组)

Matrix
Time Limit: 3000MS

Memory Limit: 65536K
Total Submissions: 21533

Accepted: 8051

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
这题是比较经典的二维树状数组,题意是给你个矩阵里面开始全是0,然后给你两种指令:1:‘C x1,y1,x2,y2’就是将左上角为x1,y1,右下角为x2,y2,的这个矩阵内的数字全部翻转,0变1,1变0,;2:'Q x1 y1',输出a[x1][y1]的值。
树状数组里记录该点的变幻次数,或者直接%2也行。查询的时候sum得到的是该点在所有区间的总变幻次数,最后%2就是结果!
这题的巧妙只初在于重叠消元,将要翻转的矩阵的四个角更新一遍就ok了,去掉重叠部分(结果%2),刚好剩下了这个矩阵翻转了!
如图 黑色的四边形为所要变换的子矩形,为了抵消其他点的变化,把不该变化的再次变化即可,记录变化次数%2,这样就可以判断了!
                   updata(x1,y1,1);    ---->>黑+黄+绿+蓝
                   updata(x1,y2+1,1);  ---->>黄+蓝
                   updata(x2+1,y1,1);  ---->>绿+蓝
                   updata(x2+1,y2+1,1);---->>蓝
                   (对应的四次变换)!
代码:
 
#include<stdio.h>
#include<string.h>
#define V 1010
int a[V][V];
int N,T;
int lowbit(int x) 
{
	return x&(-x);
}
void updata(int x,int y,int k)//更新 
{
	int i,j;
	for(i=x;i<=N;i+=lowbit(i))
	 for(j=y;j<=N;j+=lowbit(j))
	  a[i][j]+=k;
}
int sum(int x,int y)//求所在点的变化次数 
{
	int i,j;
	int sum=0;
	for(i=x;i>0;i-=lowbit(i))
	 for(j=y;j>0;j-=lowbit(j))
	   sum+=a[i][j];
	   return sum;
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&N,&T);
		memset(a,0,sizeof(a));
		while(T--)
		{
			getchar();
			char s;
			scanf("%c",&s);
			int x1,y1,x2,y2;
			if(s=='C')
			{
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				updata(x1,y1,1);//四个矩形更新 
				updata(x1,y2+1,1);
				updata(x2+1,y1,1);
				updata(x2+1,y2+1,1);
			}
			else
			{
				scanf("%d%d",&x1,&y1);
				printf("%d\n",sum(x1,y1)%2);
			}
		}
		printf("\n");
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值