PHP关于VC11,VC9,VC6以及Thread Safe和Non Thread Safe版本选择的问题

转载 2017年09月05日 15:04:08

这里是我在搭建php环境时收集的资料供大家参考:

现在PHP官网上下载php安装包都有VC11或VC9的字样,这是什么含义,我们应该下载哪种安装包更好呢?其实PHP官网给出了答案:

VC6版本是使用Visual Studio 6编译器编译的,如果你的PHP是用Apache来架设的,那你就选择VC6版本。(现在PHP已经没有VC6了)。

VC9意思就是该版本PHP是用VisualStudio2008编译的,而VC11则是用VisualStudio2012编译的。这意味着

如果你下载的是VC9版本的,就需要先安VisualC++RedistributableforVisualStudio2008SP1,

如果你下载的是VC11版本的,就需要先安VisualC++RedistributableforVisualStudio2012.

搭建php首先看操作系统的版本,如果是Windows的在这里下:http://windows.php.NET/download/

操作系统是32位还是64位?如果是32位的,就选择带“x86”的版本,如果是64位的,就选择带“x64”的版本。然后看WEB服务器是什么?如果是IIS系列,就选择带“Non Thread Safe”的版本,如果是Apache httpd系列,就选择带“Thread Safe”的版本。如果是Apache httpd还要看这个二进制版本是怎么编译的,有三种编译类型,分别是:VC6、VC9、VC11(分别代表Visual C++ 6、Visual C++ 2008、Visual C++ 2012)。这里就有麻烦了:PHP官方的最新版本5.5已经用VC11编译,5.4是用VC9编译的。可是Apache httpd的最新版本呢,至今还是用VC6编译。这意味着一个惊人的事实:Apache httpd的官方版本和PHP的官方版本竟然是无法兼容的!那现有的Windows下的Apache+PHP是怎么搞的呢?可以自己用VC11编译Apache httpd,但这太折腾了,PHP官方建议下载第三方打包好的Apache httpd版本,推荐了这个站点:http://www.apachelounge.com/download/,需要说明一点:这个VC11不支持XP,如果你像我一样有XP怀旧症,最高只能升级到5.4.24,5.5是用VC11编译的,而VC11不支持XP和2003。

如果是Linux系的在这里下载PHP的源码:http://cn2.php.net/downloads.php

与上面Windows版不同的是,这里下载到的不能直接用,只是PHP的源码,要安装需要自己编译,要编译就需要安装gcc、make等一堆编译软件。看到文档里说./configure、make、make install,针对的就是PHP的源码版本而言。

自己编译php就更麻烦了,依赖的库一大堆,等着人掉进去的坑也有一大堆,我将在另一篇文章里说。如果嫌麻烦,可以找已经编译好的版本,具体的说就是各个发行版的官方的软件库。下面以流行的ubuntu系和centos系为例分别说明;

deb包管理式(ubuntu、Debian)

用apt-cache search php命令可以搜出很多结果,我们需要是“php5”,完整的命令是:apt-get install php5

这显然不是永远适用的,因为命令中有版本号5,未来PHP6是什么情况谁也不知道。

如果想在shell中安装一个命令行的php引擎,就安装这个包

apt-getinstall php5-cli

RPM包管理(Fedora、RedHat、SUSE、CentOS)

yuminstall php

如果是php命令行,就安装yuminstall php-cli

如何选择Thread Safe和Non ThreadSafe版本?

    Windows版的PHP从版本5.2.1开始有ThreadSafe(线程安全)和None Thread Safe(NTS,非线程安全)之分,这两者不同在于何处?到底应该用哪种?这里做一个简单的介绍。

  从2000年10月20日发布的第一个Windows版的PHP3.0.17开始的都是线程安全的版本,这是由于与linux/Unix系统是采用多进程的工作方式不同的是Windows系统是采用多线程的工作方式。如果在IIS下以CGI方式运行PHP会非常慢,这是由于CGI模式是建立在多进程的基础之上的,而非多线程。一般我们会把PHP配置成以ISAPI的方式来运行,ISAPI是多线程的方式,这样就快多了。但存在一个问题,很多常用的PHP扩展是以Linux/Unix的多进程思想来开发的,这些扩展在ISAPI的方式运行时就会出错搞垮IIS。因此在IIS下CGI模式才是 PHP运行的最安全方式,但CGI模式对于每个HTTP请求都需要重新加载和卸载整个PHP环境,其消耗是巨大的。

  为了兼顾IIS下PHP的效率和安全,微软给出了FastCGI的解决方案。FastCGI可以让PHP的进程重复利用而不是每一个新的请求就重开一个进程。同时FastCGI也可以允许几个进程同时执行。这样既解决了CGI进程模式消耗太大的问题,又利用上了CGI进程模式不存在线程安全问题的优势。

     先从字面意思上理解,Thread Safe是线程安全,执行时会进行线程(Thread)安全检查,以防止有新要求就启动新线程的CGI执行方式而耗尽系统资源。Non Thread Safe是非线程安全,在执行时不进行线程(Thread)安全检查。

 因此,如果是使用ISAPI的方式来运行PHP就必须用ThreadSafe(线程安全)的版本;而用FastCGI模式运行PHP的话就没有必要用线程安全检查了,用None Thread Safe(NTS,非线程安全)的版本能够更好的提高效率。

   再来看PHP的两种执行方式:ISAPI和FastCGI。

  ISAPI执行方式是以DLL动态库的形式使用,可以在被用户请求后执行,在处理完一个用户请求后不会马上消失,所以需要进行线程安全检查,这样来提高程序的执行效率,所以如果是以ISAPI来执行PHP,建议选择Thread Safe版本;

    而FastCGI执行方式是以单一线程来执行操作,所以不需要进行线程的安全检查,除去线程安全检查的防护反而可以提高执行效率,所以,如果是以FastCGI来执行PHP,建议选择Non Thread Safe版本。

Windows PHP 中 VC6 X86 和 VC9 X86 的区别及 Non Thread Safe 的意思

PHP5.3以后 For Windows 提供了四个版本VC9 x86 Non Thread Safe、VC9 x86 Thread Safe、VC6 x86 Non Thread Safe、VC...
  • hguisu
  • hguisu
  • 2012年04月24日 10:33
  • 10692

PHP Thread Safe 与 None Thread Safe 版本的区别

/*  * PHP 版本Thread Safe 与 None Thread Safe的区别  * 从2000年发布的第一个Windows PHP版本PHP3.0.17开始都是线程安全的版本,这是由...
  • daiyutage
  • daiyutage
  • 2015年10月09日 10:08
  • 2899

PHP关于VC11,VC9,VC6以及Thread Safe和Non Thread Safe版本选择的问题

现在PHP官网上下载PHP安装包都有VC11或VC9的字样,这是什么含义,我们应该下载哪种安装包更好呢?其实PHP官网给出了答案: VC9意思就是该版本PHP是用VisualStudio2008编译...
  • you_xian
  • you_xian
  • 2014年03月20日 22:12
  • 11560

php 版本选择、线程安全(Thread Safe)和非线程安全(Non Thread Safe)

先从字面意思上理解,None-Thread Safe就是非线程安全,在执行时不进行线程(thread)安全检查;Thread Safe就是线程安全,执行时会进行线程(thread)安全检查,以防止有新...
  • Rain_Rock
  • Rain_Rock
  • 2017年06月16日 17:12
  • 1270

PHP关于VC9和VC6以及Thread Safe和Non Thread Safe版本选择的问题

一、如何选择PHP5.3的VC9版本和VC6版本     VC6版本是使用Visual Studio 6编译器编译的,如果你的PHP是用Apache来架设的,那你就选择VC6版本。     VC9版本...
  • ldb2741
  • ldb2741
  • 2009年12月04日 10:12
  • 2552

PHP关于VC9和VC6以及Thread Safe和Non Thread Safe版本选择的问题

关于VC9和VC6以及Thread Safe和Non Thread Safe版本选择的问题     最近在PHP官网上看到又有新版的PHP下载了,于是上去找找For Windows的版本,可是...
  • mengzhongshi
  • mengzhongshi
  • 2010年08月29日 12:42
  • 9504

关于PHP VC9,VC6,Thread Safe,Non Thread Safe

一、如何选择 PHP5.3 的 VC9 版本和 VC6 版本VC6 版本是使用 Visual Studio 6 编译器编译的,如果你的 PHP 是用 Apache 来架设的,那你就选择 VC6 版本。...
  • zdfcumt
  • zdfcumt
  • 2010年03月10日 17:43
  • 1881

【总结】PHP关于VC9和VC6以及Thread Safe和Non Thread Safe版本的选择

刚刚去下载Xdebug 时发现windows 下有很多版本,而这些版本是要根据自己的PHP 版本来选择的,有VC6、VC9、Thread Safe 以及Non Thread Safe。百度了一下,发现...
  • Eric6
  • Eric6
  • 2010年07月28日 12:54
  • 2161

Thread Safe(线程安全)和None Thread Safe(NTS,非线程安全)之分

Windows版的PHP从版本5.2.1开始有Thread Safe(线程安全)和None Thread Safe(NTS,非 线程安全)之分,这两者不同在于何处?到底应该用哪种?这里做一个简单的...
  • kongdeqian1988
  • kongdeqian1988
  • 2012年08月29日 13:36
  • 11815

PHP关于VC9和VC6以及Thread Safe和Non Thread Safe版本选择

今天心血来潮准备弄个论坛,想先在自己机器上弄个测试版,就需要在自己机器上安装php  for IIS版本,因为linux很少用,服务器自己维护也麻烦,所以选择IIS 了! 去php.net 去一看 ...
  • klsyp123
  • klsyp123
  • 2012年02月19日 13:16
  • 1361
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:PHP关于VC11,VC9,VC6以及Thread Safe和Non Thread Safe版本选择的问题
举报原因:
原因补充:

(最多只允许输入30个字)