PAT-甲级 1013 Battle Over Cities (25分)【图的连通性检测】

1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题意:三个数N,M,K,N代表城市的个数,M代表有几条路,K是查询的个数。

接下来M行,每行两个数A,B,代表A和B之间有一条路

然后是K个数,每个数是一种情况,代表这个城市被攻陷了。 

假如一个城市被攻陷了,那这个城市通往其他城市的路会被关掉,这时候把其余的城市都连接起来,需要修几条路,输出这个数。

在题目给的案例中,1被攻陷了,那么剩余的两个城市2和3就不连通了,所以要建1条路,输出1。

当2被攻陷的时候,剩余的两个城市1 3之间是有路的,就不需要建路,输出0。

所以题目就转换成了求连通块的数量,如果有cnt个连通块,那么就需要修cnt-1条路。

#include <bits/stdc++.h>

using namespace std;
int vis[1005];
vector < int > v[1005];
void dfs(int pos) {
    for (int i = 0; i < v[pos].size(); i++) {
        if (vis[v[pos][i]] == 0) {
            vis[v[pos][i]] = 1;
            dfs(v[pos][i]);
        }
    }
}
int main() {
    int n, m, k;

    scanf("%d %d %d", & n, & m, & k);
    for (int i = 0; i < m; i++) {
        int a, b;
        scanf("%d %d", & a, & b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    while (k--) {
        int t;
        scanf("%d", & t);
        int cnt = 0;
        vis[t] = 1;
        for (int i = 1; i <= n; i++) {
            if (vis[i] == 0) {
                dfs(i);
                cnt++;
            }
        }
        printf("%d\n", cnt - 1);
        memset(vis, 0, sizeof(vis));
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值