POJ 2299 Ultra-QuickSort 归并排序

                                                                                                                                  Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 48861 Accepted: 17868

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

Waterloo local 2005.02.05
ACcode:
#include <map>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define lolo long long
const lolo maxn=510000;
using namespace std;
lolo ans;
int a[maxn],t[maxn],n;
void _sort(int l,int r){
    if(l==r)return;
    int mid=(l+r)/2;
    _sort(l,mid);       ///左
    _sort(mid+1,r);     ///右
    int i=l,j=mid+1,now=0;
    while(i<=mid&&j<=r){
        if(a[i]>a[j]){
            ans+=mid-i+1;
            t[++now]=a[j++];
        }else {
            t[++now]=a[i++];
        }
    }
    while (i<=mid)t[++now]=a[i++];
    while (j<=r)t[++now]=a[j++];
    now=0;
    for(int k=l;k<=r;k++)a[k]=t[++now];
}
int main(){
    scanf("%d",&n);
    while(n){
        for(int i=1;i<=n;++i)scanf("%d",&a[i]);
        ans=0;
        _sort(1,n);
        cout<<ans<<'\12';
        scanf("%d",&n);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值