POJ 2299 Ultra-QuickSort

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
这个题的意思是问你冒泡排序中交换值的次数,也就是让你求序列中的逆数对之和;
对于这个问题,首先想到的是归并排序求逆数对,在二路归并的时候通过比较左右两边队头的值求得
如归并时:4 5 6 和 1 2 3 ,sum=op[1]+op[2]+op[3]=9;
这个就不多说了;
这个题也可以用树状数组来做:
首先离散化:把输入进去的数用它们所在的下标表示,排序以后它们下标的逆数就代替了它的逆数,这样的好处是使树状数组的下标之间不会差太远,起到一个压缩作用;
其后就是计算了:从数组的最后一个往第一个算,如果它不是最大的,则它到根结点的逆数都要+1;
 
下面是我用归并按自己理解写的,虽然写的跟挫,但是好懂:
LANGUAGE:C++
CODE:
#include<iostream>

using namespace std;

long long  cnt;

void merge(int array[],int left,int mid,int right)
{
	int* temp=new int[right-left+1];
	int i,j,p;
	for(i=left,j=mid+1,p=0;i<=mid&&j<=right;p++)
	{
		if(array[i]<=array[j])temp[p]=array[i++];
		else temp[p]=array[j++],cnt+=(mid-i+1);
	}
	while(i<=mid)temp[p++]=array[i++];
	while(j<=right)temp[p++]=array[j++];
	for(i=left,p=0;i<=right;i++)array[i]=temp[p++];
	delete temp;
}

void mergesort(int array[],int left,int right)
{
	if(left==right)array[left]=array[right];
	else
	{
		int mid=(left+right)/2;
		mergesort(array,left,mid);
		mergesort(array,mid+1,right);
		merge(array,left,mid,right);
	}
}
int main()
{
    int n,array[500005];
    while(cin>>n,n)
    {
        cnt=0;
        for(int i=0;i<n;i++)
            cin>>array[i];
        mergesort(array,0,n-1);
            cout<<cnt<<endl;
    }
    return 0;
}
这个是用数状数组写的,也不比归并快多少,也是NLOGN的算法;
LANGUAGE:C++
CODE:
#include<iostream>
#include<string.h>
#include<algorithm>

using namespace std;

#define maxn 500001

struct node
{
    int key;
    int to;
    bool const operator<(const struct node& a)const
    {
        return key<a.key;
    }
} data[maxn];

void update(int interval[],int n,int x,int w)
{
    for(int i=x; i<=n; i+=(i&-i))
    {
        interval[i]+=w;
    }
}

int getsum(int interval[],int x)
{
    int sum=0;
    for(int i=x; i>0; i-=(i&-i))
        sum+=interval[i];
    return sum;
}

int main()
{
    int n,interval[maxn];
    long long sum;
    while(cin>>n,n)
    {
        for(int i=1; i<=n; i++)
        {
            cin>>data[i].key;
            data[i].to=i;
        }

        sum=0;
        memset(interval,0,sizeof(interval));
        sort(data+1,data+n+1);

        for(int i=n; i>0; i--)
        {
            sum+=getsum(interval,data[i].to);
            update(interval,n,data[i].to,1);
        }

        cout<<sum<<endl;
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值