POJ - 2299 Ultra-QuickSort (归并排序)

Ultra-QuickSort

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,


Ultra-QuickSort produces the output 

0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

题目大意:对n序列从小到大排序,只能交换相邻的两个数字,至少需要交换多少次才能完成排序

思路:归并排序模板

代码:
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
const int N=5e5+10;
ll a[N],b[N],cnt;
void marge(ll a[],int s,int m,int e)
{
    int i=s,j=m+1,k=s;
    while(i<=m&&j<=e)
    {
        if(a[i]<=a[j])
            b[k++]=a[i++];
        else
        {
            cnt+=j-k;
            b[k++]=a[j++];
        }
    }
    while(i<=m) b[k++]=a[i++];
    while(j<=e) b[k++]=a[j++];
    for(int i=s;i<=e;i++)
        a[i]=b[i];
}
void mergesort(ll a[],int s,int e)
{
    if(s<e)
    {
        int m=(s+e)/2;
        mergesort(a,s,m);
        mergesort(a,m+1,e);
        marge(a,s,m,e);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {

        for(int i=1;i<=n;i++) scanf("%lld",&a[i]);
        cnt=0;
        mergesort(a,1,n);
        printf("%lld\n",cnt);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值