Eqs(sort+二分)

I - Eqs
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Consider equations having the following form: 
a1x1  3+ a2x2  3+ a3x3  3+ a4x4  3+ a5x5  3=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654
 
   
   这题是简单的二分题,没什么难度的。
 
   
AC代码:
 
   
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
#define T 105
#define inf 0x3f3f3f3f
#define CRL(a) memset(a,inf,sizeof(a))
typedef long long ll;
int a1,a2,a3,a4,a5;
vector<int> n,m;
int main()
{
	/*freopen("input.txt","r",stdin);*/
	
	int x1,x2,x3,x4,cnt,c=0;
	while(~scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5))
	{
		cnt=0;
		n.clear(),m.clear();
		for(x1=-50;x1<=50;++x1)
			if(x1)
			for(x2=-50;x2<=50;++x2)
				if(x2)
				for(x3=-50;x3<=50;++x3)
					if(x3){
						n.push_back(a1*x1*x1*x1+a2*x2*x2*x2+a3*x3*x3*x3);
					}
					for(x4=-50;x4<=50;++x4)
						if(x4)
						for(int x5=-50;x5<=50;++x5){
							if(x5)
								m.push_back(a4*x4*x4*x4+a5*x5*x5*x5);
						}
						sort(n.begin(),n.end());
						for(int i=0;i<m.size();++i){
							cnt+=upper_bound(n.begin(),n.end(),-m[i])-
								lower_bound(n.begin(),n.end(),-m[i]);
						}
						printf("%d\n",cnt);
	}
	return 0;
}


 
   
网上大牛代码(hash):
 
   
#include <stdio.h>
#include <string.h>

short hash[25000001];

int main()
{
    int a1,a2,a3,a4,a5,x1,x2,x3,x4,x5,sum;

    while(~scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5))
    {
        memset(hash,0,sizeof(hash));
        for(x1 = -50; x1<=50; x1++)
        {
            if(!x1)
                continue;
            for(x2 = -50; x2<=50; x2++)
            {
                if(!x2)
                    continue;
                sum = -1*(a1*x1*x1*x1+a2*x2*x2*x2);
                if(sum<0)
                    sum+=25000000;//数字下标没有负数,换一种出储存方式
                hash[sum]++;
            }
        }
        int cnt = 0;
        for(x3 = -50; x3<=50; x3++)
        {
            if(!x3)
                continue;
            for(x4 = -50; x4<=50; x4++)
            {
                if(!x4)
                    continue;
                for(x5 = -50; x5<=50; x5++)
                {
                    if(!x5)
                        continue;
                    sum = a3*x3*x3*x3+a4*x4*x4*x4+a5*x5*x5*x5;
                    if(sum<0)
                        sum+=25000000;
                    cnt+=hash[sum];
                }
            }
        }
        printf("%d\n",cnt);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值