Shopping(规律题)

C - Shopping
Time Limit:1000MS     Memory Limit:262144KB     64bit IO Format:%lld & %llu

Description

Input

 

Output

 

Sample Input

10 3
3 7
8 9
2 5

Sample Output

23

看懂了题目就是水题一道,因为要走最小的路程肯定是要将尽量多的重合的路一起走,这题的范围不大,直接暴力就行。

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<queue>
using namespace std;
#define T 1500
typedef long long ll;
int main()
{
	#ifdef zsc
	freopen("input.txt","r",stdin);
	#endif // zsc
	int n,m,i,j,k;
	int vis[T],x,y;
	while(~scanf("%d%d",&n,&m))
	{
		memset(vis,0,sizeof(vis));
		for(i=0;i<m;++i){
			scanf("%d%d",&x,&y);
			for(j=x+1;j<=y;++j){
				vis[j] |= 1;
			}
		}
		for(i=1,k=0;i<=n;++i){
			if(vis[i]){
				k++;
			}
		}
		printf("%d\n",(k<<1)+n+1);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值