Sort it hdu 2689

7 篇文章 0 订阅
6 篇文章 0 订阅

Problem Description

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input

3
1 2 3
4 
4 3 2 1 

Sample Output

0

6

简单的一个水题,第一次看到的时候 直接暴力俩for循环计数下就ac了。

。 但是 后来用了树状数组来写,发现真的很神奇。理解下题意。就是看

输入的时候的数前面有几个逆序数,存入数组,然后 求1到n的逆序数个数。

注意输入的时候是先更新 ,防止最后一个未算入。

暴力写法:

#include<iostream>
#include<cstring>
#include<cstdlib>
#include<string>
using namespace std;
int main()
{
	int n,i,j;
	int s[1010];
	while(cin>>n)
	{
		for(i=0;i<n;i++)
		{
			cin>>s[i];
		}
		int tot=0;
		for(i=0;i<n;i++)
		{
			for(j=i+1;j<n;j++)
			{
				if(s[i]>s[j])
				{
					int t=s[i];
					s[i]=s[j];
					s[j]=t;
					tot++;
				}
			}
		}
		cout<<tot<<endl;
	}
	return 0;
}





树状数组写法


#include<iostream>
#include<cstring>
using namespace std;
int s[1010],n;
int lowbit(int x)
{
	return x&(-x);
}

int sum(int x)
{
	int suM=0;
	while(x>0)
	{
		suM+=s[x];
		x-=lowbit(x);
	}
	return suM;
}

void updata(int x)
{
	while(x<=n)
	{
		++s[x];
		x+=lowbit(x);
	}
}

int main()
{
	int i,m;
	while(cin>>n)
	{
		memset(s,0,sizeof(s));
		int ans=0;
		for(i=1;i<=n;i++)
		{
			cin>>m;
			updata(m);
			ans+=sum(n)-sum(m);
		}
		cout<<ans<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值