POJ:2507 Crossed ladders(二分+几何数学)

Crossed ladders
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5015 Accepted: 1922

Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street? 

Input

Each line of input contains three positive floating point numbers giving the values of x, y, and c.

Output

For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

Sample Input

30 40 10
12.619429 8.163332 3
10 10 3
10 10 1

Sample Output

26.033
7.000
8.000
9.798

Source

The UofA Local 2000.10.14

题目大意:如上图所示,给出你x、y、c,分别代表两个梯子的长和交叉点距地高度,求两梯脚之间的距离?

解题思路:看图:


所以,对D进行二分,使其满足上式。

代码如下:

#include <cstdio>
#include <cmath>
double x,y,c;
bool judge(double o)
{
	double tmp1=sqrt(x*x-o*o);
	double tmp2=sqrt(y*y-o*o);
	if(tmp1*tmp2>=c*(tmp1+tmp2))
	{
		return true;
	}
	else
	{
		return false;
	}
}
double min(double x,double y)
{
	return x<y?x:y;
}
int main()
{
	int t;
	scanf("%d",&t);
	int hao=1;
	while(t--)
	{
		scanf("%lf%lf%lf",&x,&y,&c);
		double l=0,r=min(x,y);//直角边不会大于斜边
		int size=100;
		double mid;
		while(size--)
		{
			mid=(l+r)/2.0;
			if(judge(mid))
			{
				l=mid;
			}
			else
			{
				r=mid;
			}
		}
		printf("Case %d: ",hao++);
		printf("%.6lf\n",mid);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值