POJ - 2507 Crossed Ladders

Crossed Ladders
Time Limit: 2000 MS      Memory Limit: 32768 KB      64bit IO Format: %lld & %llu

Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each test case contains three positive floating point numbers giving the values of xy, and c.

Output

For each case, output the case number and the width of the street in feet. Errors less than 10-6 will be ignored.

Sample Input

4

30 40 10

12.619429 8.163332 3

10 10 3

10 10 1

Sample Output

Case 1: 26.0328775442

Case 2: 6.99999923

Case 3: 8

Case 4: 9.797958971

数学知识:设左边的墙与x的交点距地面为a,右边的墙与y的交点为b,街道宽为z,x与y的交点距左面墙为d。
则由相似三角形得:c/a=(z-d)/z;c/b=d/z。消去中间变量d得:c/a+c/b=1,即(a+b)/a*b=c,构造函数F=(a+b)/(a*b)-c=0,而a,b可通过x,y,z求出。再用二分法求解即可
#include<cstdio>  
#include<cmath>
#define eps 1e-7//精度 
double x,y,z,c;
double F(double z){
	return sqrt((x*x-z*z)*(y*y-z*z))/(sqrt(x*x-z*z)+sqrt(y*y-z*z))-c;
}//定义F函数 
int main(){
    int t,ans=1;
    scanf("%d",&t);  
    while(t--){
        scanf("%lf%lf%lf",&x,&y,&c);
        double l=0,r=x<y?x:y,mid=(l+r)/2;//区间右端点取x,y中最小值 
        printf("Case %d: ",ans++);
        while(r-l>eps){
        	if(F(mid)>0)//F(mid)>0说明mid比实际的z要小,所以舍弃左半部分区间 
        		l=mid;
			else
				r=mid;
			mid=(l+r)/2;
		}
		printf("%lf\n",mid);
    } 
    return 0;  
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值