HDU:5326 Work(并查集+小技巧统计每个人的手下个数)

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1712    Accepted Submission(s): 1028


Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.  
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
  
  
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
  
  
2
 

Author
ZSTU
 

Source
 

Recommend
wange2014
 
题目大意:
给你n-1对上下级关系,a b意味着a管理着b,再给你一个数k,问你这个公司里管理k个人的人数有多少?
解题思路:
另开一个数组,记录每个人管理多少人,输入数据,并集之后,遍历下每个元素,使他们往上找上级,每找到一个上级,说明他就归这些上级管,上级的管理人数+1,最后统计管理人数为k的人的个数。
代码如下:
#include <cstdio>
int pre[1010];
int sum[1010];
int find(int x)
{
	int r=x;
	while(r!=pre[r])
	{
		sum[pre[r]]++;//上级管理人数+1 
		r=pre[r];
	}
	return r;
}
int main()
{
	int n,k;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		for(int i=1;i<=1010;i++)
		{
			sum[i]=0;//初始化 
			pre[i]=i;
		}
		for(int i=1;i<n;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			pre[y]=x;//只并不查 
		}
		for(int i=1;i<=n;i++)
		{
			find(i);//把i统计给他上级、上级的上级,只要是他的上级,那么i就算这个上级的手下 
		}
		int cnt=0;
		for(int i=1;i<=n;i++)//统计答案 
		{
			if(sum[i]==k)
			cnt++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值