UVA - 10025 The ? 1 ? 2 ? ... ? n = k problem

 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701


 题意:

令S(n)=1 + 2 + 3 + ... + n. 其中一项为x.

那么S(n)=1 + 2 + 3 + ...+ x + ... + n. 这样结果可能大于等于 | k |

+ x 改成- x:S'(n)=1+2+...-x+...+n.

S(n)-S'(n)=2x;且k=S'(n).令y=2x.

利用 S(n)=n(n+1)/2
#include<math.h>
#include<stdio.h>
#define lli long long int
int main(){
	lli n;
	lli m;
	lli t;
	scanf("%lli",&n);
	while(n --)
	{ scanf("%lli",&m);
		m = fabs(m);

		if(m)
		{
			t = (sqrt(1 + 8*m) - 1) / 2;
			if(t*t + t != m *2 )
				t ++ ;
			while(((t*t+t)/2 - m)%2 == 1)
				t = t+ 1;
			printf("%lli\n",t);


		}

		else
			printf("3\n");
		if(n)
			printf("\n");

	}
	return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值