第三次训练——The ? 1 ? 2 ? ... ? n = k problem

The ? 1 ? 2 ? ... ? n = k problem 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701
注意题目要求的格式:多组数据的测试,每组自定义要测试的次数,且次数与次数之间有一个空行隔开,组与组之间没有空行。
#include <stdio.h>
#include <math.h>

int main()
{
    long long sum,n,t,k,i,cha,j,z;
    while(scanf("%lld",&n)!=EOF)
    {
        while(n--)
        {
            z = 0;
            sum = 0;
            scanf("%lld",&t);
            t = abs(t);

            for(i = 1;; i++)
            {
                sum = sum + i;
                if(sum==t)
                {
                    printf("%lld\n",i);
                    break;
                }
                else if((sum>t) && ((sum - t)%2 == 0) && (sum - t)<=(i*(i+1)))
                {
                    printf("%lld\n",i);
                    break;
                }
            }
            if(n>0)
                printf("\n");
        }
    }
    return 0;
}
上面是我自己写的代码,下面的是别人的代码,下面的运行时间更短
#include<stdio.h>
int main()
{
 int n,j;
 while(scanf("%d",&n)!=EOF)
 {
  while(n--)
  {
   int num,k=0,sum=0,p;
   scanf("%d",&num);
   if(num==0) printf("3\n");
   else
   {
      if(num<0) num=-num;
      while(sum<num){
      k++;
      sum+=k;
      }
      p=sum-num;
      if(p%2==0)  printf("%d\n",k);
      else
      {
      for(j=k+1;;j++)
      {
      p=p+j;
      if(p%2==0){
      printf("%d\n",j);
      break;
      }
      }
      }
   }

   if(n) printf("\n");
  }

 }
 return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值