C++离散化

/*
假定有一个无限长的数轴,数轴上每个坐标上的数都是 0。

现在,我们首先进行 n 次操作,每次操作将某一位置 x 上的数加 c。

接下来,进行 m 次询问,每个询问包含两个整数 l 和 r,你需要求出在区间 [l,r] 之间的所有数的和。

输入格式

第一行包含两个整数 n 和 m。

接下来 n 行,每行包含两个整数 x 和 c。

再接下来 m 行,每行包含两个整数 l 和 r。

输出格式

共 m 行,每行输出一个询问中所求的区间内数字和。

数据范围

−10^9≤x≤10^9
1≤n,m≤10^5
−10^9≤l≤r≤10^9
−10000≤c≤10000

输入样例:
3 3
1 2
3 6
7 5
1 3
4 6
7 8

输出样例:
8
0
5
*/
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
// 用pair来存储要输入和输出的信息
typedef pair<int, int> PII;
const int N = 300010;
// n为要输入的个数,m为要输出的个数
int n, m;
// a[N]用来存储数值,s[N]用来存储前缀和
int a[N], s[N];
// alls用来统计总的不重复的个数
vector<int> alls;
vector<PII> add, query;
// 二分求出x对应的离散化的值
int find(int x) { // 找到第一个大于等于x的位置
    int l = 0, r = alls.size() - 1;
    while(l < r) {
        int mid = (l + r) >> 1;
        if(alls[mid] >= x) {
            r = mid;
        }else {
            l = mid + 1;
        }
    }
    return r + 1; //映射到1,2...n
}
vector<int>::iterator unique(vector<int>& a) {
    int j = 0;
    for(int i = 0; i < a.size(); i++) {
        // 它是第一个或者和前面一个数不同
        if(!i || a[i] != a[i - 1]) {
            a[j++] = a[i];
        }
    }
    // a[0] ~ a[j - 1] 存储a中重复的数
    return a.begin() + j;
}
int main()
{
    cin >> n >> m;
    for(int i = 0; i < n; i++) {
        int x, c;
        cin >> x >> c;
        add.push_back(make_pair(x, c));
        alls.push_back(x);
    }
    
    for(int i = 0; i < m; i++) {
        int l, r;
        cin >> l >> r;
        query.push_back(make_pair(l, r));
        alls.push_back(l);
        alls.push_back(r);
    }
    // 排序后去重
    sort(alls.begin(), alls.end());
    alls.erase(unique(alls.begin(), alls.end()), alls.end());

    for(PII item: add) {
        int x = find(item.first);
        a[x] += item.second;
    }

    for(int i = 1; i <= alls.size(); i++) {
        s[i] = s[i - 1] + a[i];
    }

    for(PII item: query) {
        int l = find(item.first);
        int r = find(item.second);
        cout << s[r] - s[l - 1] << endl;
    }

    return 0;
}

  • 6
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值