1004 成绩排名分数

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
  ... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

代码长度限制 16 KB

时间限制 400 ms

内存限制 64 MB

解题思路:有姓名,学号,分数,优先考虑创建学生类,之后筛选符合条件的对象加入列表里,用流给其排序,最后取头尾数据即可。

y解题代码:

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;
import java.util.stream.Collectors;
 class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int max = sc.nextInt();
        sc.nextLine();            //去掉缓冲区的回车符
        ArrayList<Student> students = new ArrayList<>();
        for (int i = 0; i < max; ) {
            String s = sc.nextLine();       
            String[] split = s.split("\\s");             //裁剪字符串
            String name = split[0];
            String order = split[1];
            int souse = Integer.parseInt(split[2]);
            if (name.length() >= 10 && order.length() >= 10 && souse > 100)
                continue;
            students.add(new Student(name, order, souse));
            i++;
        }
        List<Student> students1 = students.stream().sorted((o1, o2) -> o2.souse - o1.souse).collect(Collectors.toList());
        System.out.println(students1.get(0).name + " " + students1.get(0).order);
        System.out.println(students1.get(max - 1).name + " " + students1.get(max - 1).order);
    }}

//定义学生类
     class Student {
        String name;
        String order;
        int souse;

        public Student(String name, String order, int souse) {
            this.name = name;
            this.order = order;
            this.souse = souse;
        }
    }
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值