POJ 1611题解(并查集)

本文介绍了一种在NSYSU大学中,利用并查集数据结构算法解决如何在发现单个学生为疑似SARS病例时,快速确定所有可能被传染的学生群体的问题。程序通过合并具有传染关系的学生群体来找出所有疑似病例。
摘要由CSDN通过智能技术生成

The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 78906Accepted: 37166

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int N=300005;
int parents[N],height[N];
int n,m;

int find_set(int x)
{
	return x==parents[x]? x:x=find_set(parents[x]);
}
void union_set(int a,int b)
{
	int x=find_set(a),y=find_set(b);
	if(height[x]==height[y])
	{
		height[x]++;
		parents[y]=x;
	}
	else
	{
		if(height[x]>height[y])
		   parents[y]=x;
		else
		  parents[x]=y;
	}
}
int main()
{
	while(scanf("%d%d",&n,&m)&&(n||m))
	{
		memset(height,0,sizeof height);
		for(int i=0;i<n;i++)
		  parents[i]=i;
		int u,x,ans=0,y;
		for(int j=0;j<m;j++)
		{
			scanf("%d%d",&u,&x);	
			for(int i=0;i<u-1;i++)
			{
				scanf("%d",&y);
				union_set(x,y);
			}			
		}
		for(int i=0;i<n;i++)
		  if(find_set(i)==find_set(0))//找真正的父亲节点,而不是parents
		    ans++;
		printf("%d\n",ans);
	}
	return 0;
}

  • 48
    点赞
  • 30
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值