AtCoder342-A

A - Yay!

Problem Statement

You are given a string S consisting of lowercase English letters. The length of S is between 33 and 100100, inclusive.

All characters but one of S are the same.

Find x such that the x-th character of S differs from all other characters.

Constraints

  • S is a string of length between 33 and 100, inclusive, consisting of two different lowercase English letters.
  • All characters but one of S are the same.

    Input

    The input is given from Standard Input in the following format:

    S
    

    Output

    Print the answer.

    Sample Input 1Copy

    Copy

    yay
    

    Sample Output 1Copy

    Copy

    2
    

    The second character of yay differs from the first and third characters.

    Sample Input 2Copy

    Copy

    egg
    

    Sample Output 2Copy

    Copy

    1

    Sample Input 3Copy

    Copy

    zzzzzwz
    

    Sample Output 3Copy

    Copy

    6
    
    #include <iostream>
    #include <bits/stdc++.h>
    using namespace std;
    int main(){
    	string s;
    	cin>>s;
    	int ch[27]={0};
    	int first[27]={0};
    	s="#"+s;
    	int len=s.length();
    	for(int i=1;i<=len;i++){
    		if(s[i]>='a'&&s[i]<='z'){
    			ch[s[i]-'a'+1]++;
    			if(ch[s[i]-'a'+1]==1&&first[s[i]-'a'+1]==0){
    				first[s[i]-'a'+1]=i;
    			}
    		}
    	}
    	for(int i=1;i<=26;i++){
    		if(ch[i]==1){
    			cout<<first[i];
    			break;
    		}
    	}
    	return 0;
    }

  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值