Not Found

题目描述

You are given a string S consisting of lowercase English letters. Find the lexicographically (alphabetically) smallest lowercase English letter that does not occur in S. If every lowercase English letter occurs in S, print None instead.

Constraints
1≤|S|≤105 (|S| is the length of string S.)
S consists of lowercase English letters.

输入

Input is given from Standard Input in the following format:
S

输出

Print the lexicographically smallest lowercase English letter that does not occur in S. If every lowercase English letter occurs in S, print None instead.

样例输入

atcoderregularcontest

样例输出

b

提示

The string atcoderregularcontest contains a, but does not contain b.

题解:水题,将字符串所有字母都编程数字加入相同数组,最后扫一次看是否有字母没有出现过。

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int a[30]={0},i=0,k=-1,s;
    string str;
    cin>>str;
    while(str[i])//将字符串所有字母读入
    {
        s=str[i]-'a'+1;
        a[s]++;
        i++;
    }
    for(int j=1;j<=26;j++)//26个字母扫一遍,遇0停止
    {
        if(a[j]==0)
        {
            k=1;
            printf("%c\n",'a'+j-1);
            break;
        }
    }
    if(k==-1)
    {
        cout<<"None"<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值