第一步:IP地址规划
第二步:配置IP地址
R1配置
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
[R1-Serial4/0/0]ip address 15.1.1.1 24
R2配置
[R2-GigabitEthernet0/0/0]ip address 192.168.2.1 24
[R2-Serial4/0/0]ip address 25.1.1.1 24
R3配置
[R3-Serial4/0/0]ip address 35.1.1.1 24
[R3-GigabitEthernet0/0/0]ip address 192.168.3.1 24
R4配置
[R4-GigabitEthernet0/0/0]ip address 45.1.1.1 24
[R4-GigabitEthernet0/0/1]ip address 192.168.4.1 24
R5配置
[R5-Serial4/0/0]ip address 15.1.1.5 24
[R5-Serial4/0/1]ip address 25.1.1.5 24
[R5-Serial3/0/0]ip address 35.1.1.5 24
[R5-GigabitEthernet0/0/0]ip address 45.1.1.5 24
[R5-LoopBack0]ip address 5.5.5.1 24
第三步:配置缺省路由
[R1]ip route-static 0.0.0.0 0 15.1.1.5
[R2]ip route-static 0.0.0.0 0 25.1.1.5
[R3]ip route-static 0.0.0.0 0 35.1.1.5
[R4]ip route-static 0.0.0.0 0 45.1.1.5
第四步:NAT
[R3]acl 2000
[R3-acl-basic-2000]rule 1 permit source any
[R3]interface s4/0/0
[R3-Serial4/0/0]nat outbound 2000
第五步:PAP认证
认证方
[R5]aaa
[R5-aaa]local-user huawei password cipher huawei
[R5-aaa]local-user huawei service-type ppp
[R5]interface s4/0/0
[R5-Serial4/0/0]ppp authentication-mode pap
被认证方
[R1]interface s4/0/0
[R1-Serial4/0/0]ppp pap local-user huawei password cipher huawei
第六步:CHAP认证
认证方
[R5]aaa
[R5-aaa]local-user huawei password cipher huawei
[R5-aaa]local-user huawei service-type ppp
[R5]interface s4/0/0
[R5-Serial4/0/0]ppp authentication-mode chap
被认证方
[R2]interface s4/0/0
[R2-Serial4/0/0]ppp chap user huawei
[R2-Serial4/0/0]ppp chap password cipher huawei
第七步:HDCL封装
[R3]interface s4/0/0
[R3-Serial4/0/0]link-protocol hdlc
[R5]interface s3/0/0
[R5-Serial3/0/0]link-protocol hdlc
第八步:构建MGRE环境
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]source 15.1.1.1
[R1-Tunnel0/0/0]nhrp network-id 100
[R2]interface Tunnel 0/0/0
[R2-Tunnel0/0/0]ip address 10.1.1.2 24
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp
[R2-Tunnel0/0/0]source s4/0/0
[R2-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register
[R2-Tunnel0/0/0]nhrp network-id 100
[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 10.1.1.3 24
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]source s4/0/0
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register
[R3-Tunnel0/0/0]nhrp network-id 100
第九步:配置GRE
[R1]interface Tunnel 0/0/1
[R1-Tunnel0/0/1]ip address 20.1.1.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre
[R1-Tunnel0/0/1]source 15.1.1.1
[R1-Tunnel0/0/1]destination 45.1.1.1
[R4]interface Tunnel 0/0/1
[R4-Tunnel0/0/1]ip address 20.1.1.2 24
[R4-Tunnel0/0/1]tunnel-protocol gre
[R4-Tunnel0/0/1]source 45.1.1.1
[R4-Tunnel0/0/1]destination 15.1.1.1
第⼗步:书写RIP路由
MGRE环境下RIP路由配置
[R4]rip 1
[R4-rip-1]version 2
[R4-rip-1]network 192.168.1.0
[R4-rip-1]network 10.0.0.0