6-5 E. DS树--二叉树高度

题目描述

给出一棵二叉树,求它的高度。

注意,二叉树的层数是从1开始

输入

第一行输入一个整数t,表示有t个二叉树

第二行起输入每个二叉树的先序遍历结果,空树用字符‘0’表示,连续输入t行

输入样例:

1
AB0C00D00

输出

每行输出一个二叉树的高度

输出样例:

3

代码

#include <iostream>
using namespace std;

struct Node{
    char data;
    Node *left;
    Node *right;
};

class Tree{
public:
    Node *root;
    void create(Node *&t){
        char c;
        cin >> c;
        if(c == '0'){
            t = NULL;
        }else{
            t = new Node;
            t->data = c;
            create(t->left);
            create(t->right);
        }
    }

    int height(Node *t){  //递归求二叉树高度
        if(t == NULL){
            return 0;
        }else if(t->left == NULL && t->right == NULL) {  //叶子结点 return 1
            return 1;
        }
        int lheight = height(t->left);
        int rheight = height(t->right);
        if(lheight > rheight){
            return lheight+1;
        }else{
            return rheight+1;
        }
    }
};

int main()
{
    int t;
    cin >> t;
    while(t--){
        Tree tree;
        tree.create(tree.root);
        int height = tree.height(tree.root);
        cout << height << endl;
    }
    return 0;
}
  • 14
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值