TZOJ:1364: Team Queue

本文介绍了一种不常见的数据结构——团队队列,它在实际生活中如午餐队伍中有应用。任务是编写程序模拟这种队列,其中元素属于同一团队,遵循特定的队列规则。
摘要由CSDN通过智能技术生成

 标签:队列

描述

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.
Your task is to write a program that simulates such a team queue.

输入

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.
Finally, a list of commands follows. There are three different kinds of commands:
ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

输出

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

样例输入

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

样例输出

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

#include <iostream>
#include <queue>
using namespace std;

const int N = 1010, M = 1000010;
int team_id[M]; // 存储每个人所在的小组编号

int main()
{
    int t, k = 1;
    while (cin >> t, t)
    { 
        cout << "Scenario #" << k ++ << '\n';
        for (int i = 0; i < t; i++)
        {
            int n;
            cin >> n;
            while (n--) 
            {
                int x;
                cin >> x;
                team_id[x] = i; // 记录每个人所在的小组编号
            }
        }

        queue<int> team; // 存储当前排队的小组编号
        queue<int> person[N]; // 存储每个小组中正在排队的人员编号

        string op;
        while (cin >> op, op != "STOP") // 处理命令列表
        { 
            if (op == "ENQUEUE")// 入队操作
            { 
                int x;
                cin >> x;

                int id = team_id[x]; // 获取该人所在的小组编号
                if (person[id].empty()) team.push(id); // 如果该小组还没有任何人正在排队,则将其加入到队列中
                person[id].push(x); // 将该人加入到对应的小组队列中
            } 
            else // 出队操作
            { 

                int id = team.front(); // 获取当前排在最前面的小组编号
                cout << person[id].front() << '\n'; // 输出该小组中排在最前面的人员编号
                person[id].pop(); // 从队列中弹出该人员
                if (person[id].empty()) team.pop(); // 如果该小组没有其他人员在排队,则将其从队列中弹出
            }
        }

        puts(""); // 输出换行不要忘记(^-^) 
    }

    return 0;
}
  • 20
    点赞
  • 22
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值