TZOJ:1318: Hangover

描述

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

输入

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

输出

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

样例输入

1.00
3.71
0.04
5.19
0.00

样例输出

3 card(s)
61 card(s)
1 card(s)
273 card(s)

注意输出格式

#include <stdio.h>

double dg(double n)
{
	double i = 2,ans = 0;
	while(ans < n) // 正常的一个循环累加 
	{
		ans = 1 / i + ans;
		i ++;
	}
	return i - 2; //i初始化是2,所以减2 
}

int main() 
{
	/* 初始化 */ 
	int i = 0 , sum;
	double a[100] = {0};
	
    while(i >= 0)
    {
    	/* 正常读入 */ 
    	scanf("%lf" , &a[i]);
    	if(a[i] == 0.00) // 判断结束条件 
    		break;
		
		sum = dg(a[i]); // 调用函数 
    	printf("%d card(s)\n" , sum); //不要忘记输出换行(^-^) 
    	i ++;	
	}
    return 0;
}
  • 15
    点赞
  • 17
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值