Petya and Strings

Petya and Strings

题面翻译

输入两个字符串,大小写无关紧要,比较它们的大小。

输入格式

两个字符串(保证长度相等)

输出格式

如果第一个字符串小于第二个字符串,则输出“-1”。如果第二个字符串小于第一个字符串,则输出“1”。如果字符串相同,则打印“0”。请注意,比较字符串时不考虑字母的大小写。

题目描述

Little Petya loves presents. His mum bought him two strings of the same size for his birthday. The strings consist of uppercase and lowercase Latin letters. Now Petya wants to compare those two strings lexicographically. The letters’ case does not matter, that is an uppercase letter is considered equivalent to the corresponding lowercase letter. Help Petya perform the comparison.

输入格式

Each of the first two lines contains a bought string. The strings’ lengths range from $ 1 $ to $ 100 $ inclusive. It is guaranteed that the strings are of the same length and also consist of uppercase and lowercase Latin letters.

输出格式

If the first string is less than the second one, print “-1”. If the second string is less than the first one, print “1”. If the strings are equal, print “0”. Note that the letters’ case is not taken into consideration when the strings are compared.

样例 #1

样例输入 #1

aaaa
aaaA

样例输出 #1

0

样例 #2

样例输入 #2

abs
Abz

样例输出 #2

-1

样例 #3

样例输入 #3

abcdefg
AbCdEfF

样例输出 #3

1

提示说明

If you want more formal information about the lexicographical order (also known as the “dictionary order” or “alphabetical order”), you can visit the following site:

  • http://en.wikipedia.org/wiki/Lexicographical_order

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    string x,y;
    cin>>x>>y;

    for(auto &t:x)
    {
        if(isupper(t)) t+=32;
    }
    for(auto &t:y)
    {
        if(isupper(t)) t+=32;
    }

    if(x<y) cout<<-1<<endl;
    else if(x>y) cout<<1<<endl;
    else cout<<0<<endl;
    
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值