Chat room

Chat room

题面翻译

给定一个字符串使删除这个字符串的一些字符使它变成“hello”

题目描述

Vasya has recently learned to type and log on to the Internet. He immediately entered a chat room and decided to say hello to everybody. Vasya typed the word $ s $ . It is considered that Vasya managed to say hello if several letters can be deleted from the typed word so that it resulted in the word “hello”. For example, if Vasya types the word “ahhellllloou”, it will be considered that he said hello, and if he types “hlelo”, it will be considered that Vasya got misunderstood and he didn’t manage to say hello. Determine whether Vasya managed to say hello by the given word $ s $ .

输入格式

The first and only line contains the word $ s $ , which Vasya typed. This word consisits of small Latin letters, its length is no less that 1 and no more than 100 letters.

输出格式

If Vasya managed to say hello, print “YES”, otherwise print “NO”.

样例 #1

样例输入 #1

ahhellllloou

样例输出 #1

YES

样例 #2

样例输入 #2

hlelo

样例输出 #2

NO

Code

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

typedef long long ll;

using namespace std;
string a={"hello"};

int main()
{
    string s;
    cin>>s;
    
    int op=0;
    for(int i=0,j=0;i<s.size();i++)
    {
        if(s[i]==a[j]) j++;
        if(j==5) {op=1;break;}
    }
    
    if(op) cout<<"YES"<<endl;
    else cout<<"NO"<<endl;
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值