1111111

1、划分ip

[R1]int g0/0/0

[R1-GigabitEthernet0/0/0]ip add 192.168.1.254 24

[R1]int Serial 4/0/0

[R1-Serial4/0/0]ip add 15.1.1.1 24

[R2]int g0/0/0

[R2-GigabitEthernet0/0/0]ip add 192.168.2.254 24

[R2]int Serial 4/0/0

[R2-Serial4/0/0]ip add 25.1.1.2 24

[R3]int g0/0/0

[R3-GigabitEthernet0/0/0]ip add 192.168.3.254 24

[R3]int Serial 4/0/0

[R3-Serial4/0/0]ip add 35.1.1.3 24

[R4]int g0/0/1

[R4-GigabitEthernet0/0/1]ip add 192.168.4.254 24

[R4]int g0/0/0

[R4-GigabitEthernet0/0/0]ip add 45.1.1.4 24

[ISP]int g0/0/0

[ISP-GigabitEthernet0/0/0]ip add 45.1.1.5 24

[ISP]int Serial 4/0/1

[ISP-Serial4/0/1]ip add 15.1.1.5 24

[ISP-Serial4/0/1]int Serial 3/0/1

[ISP-Serial3/0/1]ip add 25.1.1.5 24

[ISP]int Serial 4/0/0

[ISP-Serial4/0/0]ip add 35.1.1.5 24

[ISP]int l0

[ISP-LoopBack0]ip add 5.5.5.5 24

2、R1和R5的PAP认证,R5为主认证方。

所以需要在 R5上创建用于验证的用户,且pap认证方式会明文传递用户名和密码。

主认证方:

[ISP]aaa

[ISP-aaa]local-user zhuyy privilege level 15 password cipher 123456dd

[ISP-aaa]local-user zhuyy service-type ppp

[ISP]int Serial 4/0/1   

[ISP-Serial4/0/1]ppp authentication-mode pap

[R1]int Serial 4/0/0     

[R1-Serial4/0/0]ppp pap local-user zhuyy password cipher 123456dd

3、R2与R5chap认证,R5为主认证方

[ISP]aaa

[ISP-aaa]local-user zhuyy privilege level 15 password cipher wdy12345

[ISP-aaa]local-user zhuyy service-type ppp

[ISP]int Serial 4/0/0

[ISP-Serial4/0/0]ppp authentication-mode chap

[R2]int Serial 4/0/0

[R2-Serial4/0/0]ppp chap user zhuyy

[R2-Serial4/0/0]ppp chap password cipher wdy12345

  1. 完成R3与R5之间为HDLC封装。

[R3]int Serial 4/0/0

[R3-Serial4/0/0]link-protocol hdlc  Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]

:y

[ISP]int Serial 4/0/0

[ISP-Serial4/0/0]link-protocol hdlc

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]

:y

5、出口设备配置缺省路由

[R1]ip route-static 0.0.0.0 0 15.1.1.5

[R2]ip route-static 0.0.0.0 0 25.1.1.5

[R3]ip route-static 0.0.0.0 0 35.1.1.5

[R4]ip route-static 0.0.0.0 0 45.1.1.5

6、完成R1与R4为点到点GRE

[R1]interface Tunnel0/0/0

[R1-Tunnel0/0/0]ip address 10.1.1.1 24 建立隧道接口IP地址

[R1-Tunnel0/0/0]tunnel-protocol gre

[R1-Tunnel0/0/0]source 15.1.1.1

[R1-Tunnel0/0/0]destination 45.1.1.4

[R4]interface Tunnel 0/0/0

[R4-Tunnel0/0/0]ip add 10.1.1.2 24   

[R4-Tunnel0/0/0]tunnel-protocol gre

[R4-Tunnel0/0/0]source 45.1.1.4

[R4-Tunnel0/0/0]destination 15.1.1.1

7、完成R1/2/3构建MGRE,R1为中心站点

[R1]interface Tunnel 0/0/1    

[R1-Tunnel0/0/1]ip address 10.1.2.1 24    

[R1-Tunnel0/0/1]tunnel-protocol gre p2mp

[R1-Tunnel0/0/1]source 15.1.1.1   

[R1-Tunnel0/0/1]nhrp entry multicast dynamic

[R1-Tunnel0/0/1]nhrp network-id 100  

分支站点的配置:

[R2]interface Tunnel 0/0/1

[R2-Tunnel0/0/1]ip address 10.1.2.2 24

[R2-Tunnel0/0/1]tunnel-protocol gre p2mp   

[R2-Tunnel0/0/1]source serial 4/0/0

[R2-Tunnel0/0/1]nhrp entry 10.1.2.1 15.1.1.1 register

[R2-Tunnel0/0/1]nhrp network-id 100

[R3]interface Tunnel 0/0/1

[R3-Tunnel0/0/1]ip add 10.1.2.3 24

[R3-Tunnel0/0/1]tunnel-protocol gre p2mp

[R3-Tunnel0/0/1]source Serial 4/0/0

[R3-Tunnel0/0/1]nhrp network-id 100

[R3-Tunnel0/0/1]nhrp entry 10.1.2.1 15.1.1.1 register

8、配置RIP.,宣告网段

[R1]rip 1

[R1-rip-1]version 2

[R1-rip-1]undo summary

[R1-rip-1]network 192.168.1.0

[R1-rip-1]network 10.0.0.0

[R2]rip 1

[R2-rip-1]version 2

[R2-rip-1]network 192.168.2.0

[R2-rip-1]network 10.0.0.0

[R2-rip-1]undo summary

[R3]rip 1

[R3-rip-1]version 2

[R3-rip-1]undo summary

[R3-rip-1]network 192.168.3.0

[R3-rip-1]network 10.0.0.0

[R4]rip 1

[R4-rip-1]version 2

[R4-rip-1]undo summary

[R4-rip-1]network 192.168.4.0

[R4-rip-1]network 10.0.0.0

[R1]int Tunnel 0/0/1

[R1-Tunnel0/0/1]undo rip split-horizon

9、网段配置NAT。

[R1]acl 2000

[R1-acl-basic-2000]rule  permit source 192.168.1.0 0.0.0.255

[R1]int Serial 4/0/0

[R1-Serial4/0/0]nat outbound 2000

[R2]acl 2000

[R2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255

[R2]int Serial 4/0/0

[R2-Serial4/0/0]nat outbound 2000

[R3]acl 2000

[R3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255

[R3]int Serial 4/0/0

[R3-Serial4/0/0]nat outbound 2000

[R4]acl 2000

[R4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255

[R4]int g0/0/0

[R4-GigabitEthernet0/0/0]nat outbound 2000

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值