04-树6 Complete Binary Search Tree(C)

日常,满分,哈哈只需记住,值不变切地址

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

我的AC: 

  关键函数:void Insert_Tree(CBT T, int start, int end, int *n, int* t);

void Insert_Tree(CBT T, int start, int end, int *n, int* t)
{
	if(start > end){
		return ;
	}
	int left = 2 * start;
	int right = 2 * start + 1;
	if(left <= end){
		Insert_Tree(T, left, end, n, t);
	}
	T ->data[start] = t[(*n)++];
	if(right <= end){
		Insert_Tree(T, right, end, n, t);
	}
}

#include<stdio.h>
#include<stdlib.h>

typedef struct TNode *CBT;
struct TNode{
	int *data;
};

CBT Build_Tree(int num);
CBT Init_Tree(int num);
void Bubble_Sort(int *t, int num);
void Insert_Tree(CBT T, int start, int end, int *n, int* t);
void Print_Tree(CBT T, int num);
void Free_Tree(CBT T);

int main()
{
	CBT T;
	int num;
	scanf("%d", &num);
	T = Build_Tree(num);
	Print_Tree(T, num);
	Free_Tree(T);
	return 0;
}
CBT Build_Tree(int num)
{
	CBT T;
	int *t, *n;
	int degree = 1;
	n = &degree;
	T = Init_Tree(num);
	t = (int*)calloc((num + 5), sizeof(int));
	for(int i = 1; i<= num; i++){
		scanf("%d", &t[i]);
	}
	Bubble_Sort(t, num);
	Insert_Tree(T, 1, num, n, t);
	return T;
}
CBT Init_Tree(int num)
{
	CBT T;
	T = (CBT)malloc(sizeof(struct TNode));
	T ->data = (int *)calloc((num+5), sizeof(int));
	return T;
}
void Bubble_Sort(int *t, int num)
{
	int Temp, count;
	for(int i = 1; i< num;i++){
		count = 0;
		for(int j = 1; j< num; j++){
			if(t[j] > t[j+1]){
				Temp = t[j];
				t[j] = t[j+1];
				t[j+1] = Temp;
				count = 1;
			}	
		}
		if(count == 0){
			break;
		}
	}
}
void Insert_Tree(CBT T, int start, int end, int *n, int* t)
{
	if(start > end){
		return ;
	}
	int left = 2 * start;
	int right = 2 * start + 1;
	if(left <= end){
		Insert_Tree(T, left, end, n, t);
	}
	T ->data[start] = t[(*n)++];
	if(right <= end){
		Insert_Tree(T, right, end, n, t);
	}
}

void Print_Tree(CBT T, int num)
{
	for(int i = 1; i< num; i++){
		printf("%d ", T->data[i]);
	}
	printf("%d", T->data[num]);
}
void Free_Tree(CBT T)
{
	free(T ->data);
	free(T);
}

  • 13
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值