题目描述
设有n个正整数(n≤20),将它们联接成一排,组成一个最大的多位整数。
例如:n=3时,3个整数13,312,343联接成的最大整数为:34331213
又如:n=4时,4个整数7,13,4,246联接成的最大整数为:7424613
输入
输入分2行
第一行是n
第2行是n个整数
输出
连接成的多位数
样例输入 Copy
3 13 312 343
样例输出 Copy
34331213
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int N = 2e5 + 10000;
bool compare(const string& a, const string& b)
{
return a + b > b + a;
}
int main()
{
int n;
cin >> n;
vector<string> numbers(n);
for (int i = 0; i < n; i++)
{
cin >> numbers[i];
}
sort(numbers.begin(), numbers.end(), compare);
for (int i = 0; i < n; i++)
{
cout << numbers[i];
}
cout << endl;
return 0;
}