atcoder ABC 359-A题详解

atcoder ABC 359-A题详解

Problem Statement

You are given N strings.

The i-th string Si(1≤i≤N) is either Takahashi or Aoki.

How many i are there such that Si is equal to Takahashi?

Constraints

1≤N≤100
N is an integer.
Each Si is Takahashi or Aoki. (1≤i≤N)

Input

The input is given from Standard Input in the following format:

N
S1
S2

SN

Output

Print the count of i such that Si is equal to Takahashi as an integer in a single line.

Sample Input 1

3
Aoki
Takahashi
Takahashi

Sample Output 1

2
S2 and S3 are equal to Takahashi, while S1 is not.

Therefore, print 2.

Sample Input 2

2
Aoki
Aoki

Sample Output 2

0
It is possible that no Si is equal to Takahashi.

Sample Input 3

20
Aoki
Takahashi
Takahashi
Aoki
Aoki
Aoki
Aoki
Takahashi
Aoki
Aoki
Aoki
Takahashi
Takahashi
Aoki
Takahashi
Aoki
Aoki
Aoki
Aoki
Takahashi

Sample Output 3

7

思路分析:

本题需要来判断有多少个Takahashi,可以用ans来统计数量,用if来判断。

code:

#include <iostream>
#include <string>
using namespace std;
int n;
string s;
int ans=0;
int main(){
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>s;
        if(s=="Takahashi") ans++;
    }
    cout<<ans;
}
  • 8
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值