atcoder ABC 359-A题详解
Problem Statement
You are given N strings.
The i-th string Si(1≤i≤N) is either Takahashi or Aoki.
How many i are there such that Si is equal to Takahashi?
Constraints
1≤N≤100
N is an integer.
Each Si is Takahashi or Aoki. (1≤i≤N)
Input
The input is given from Standard Input in the following format:
N
S1
S2
⋮
SN
Output
Print the count of i such that Si is equal to Takahashi as an integer in a single line.
Sample Input 1
3
Aoki
Takahashi
Takahashi
Sample Output 1
2
S2 and S3 are equal to Takahashi, while S1 is not.
Therefore, print 2.
Sample Input 2
2
Aoki
Aoki
Sample Output 2
0
It is possible that no Si is equal to Takahashi.
Sample Input 3
20
Aoki
Takahashi
Takahashi
Aoki
Aoki
Aoki
Aoki
Takahashi
Aoki
Aoki
Aoki
Takahashi
Takahashi
Aoki
Takahashi
Aoki
Aoki
Aoki
Aoki
Takahashi
Sample Output 3
7
思路分析:
本题需要来判断有多少个Takahashi,可以用ans来统计数量,用if来判断。
code:
#include <iostream>
#include <string>
using namespace std;
int n;
string s;
int ans=0;
int main(){
cin>>n;
for(int i=0;i<n;i++){
cin>>s;
if(s=="Takahashi") ans++;
}
cout<<ans;
}