L2-012 关于堆的判断

将一系列给定数字顺序插入一个初始为空的最小堆。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第 1 行包含 2 个正整数 n(≤ 1000)和 m(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间 [−10000,10000] 内的 n 个要被插入一个初始为空的最小堆的整数。之后 m 行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出 T,否则输出 F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

重点在于建立小顶堆,他首先是一个完全二叉树,依次添加节点判断大小并移动即可。 

 代码

#include<bits/stdc++.h>
using namespace std;
int n,m;
int a[1010];
int f(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(a[i]==x) return i;
	}
	return 0;
}
int main()
{
	cin>>n>>m;
	for(int i=1;i<=n;i++)//建立小顶堆 
	{
		cin>>a[i];//加到完全树中 
		int k=i;
		while(k>1&&a[k]<a[k/2])//与父结点比较 小的在上 
		{
			swap(a[k],a[k/2]);
			k=k/2;
		}
	}
	while(m--)
	{
		int x;
		string s;
		cin>>x>>s;
		if(s=="is")
		{
			string ss;
			cin>>ss;
			if(ss=="the")
			{
				string sss;
				cin>>sss;
				if(sss=="root")
				{
					if(a[1]==x) cout<<"T"<<endl;
					else cout<<"F"<<endl;
				}
				else
				{
					int y;
					cin>>sss>>y;
					if(f(x)==f(y)/2) cout<<"T"<<endl;
					else cout<<"F"<<endl;
				}
			}
			else
			{
				string s1,s2;
				int y;
				cin>>s1>>s2>>y;
				if(f(x)/2==f(y)) cout<<"T"<<endl;
				else cout<<"F"<<endl;
			}
		}
		else
		{
			int y;
			string s1,s2;
			cin>>y>>s1>>s2;
			if(f(x)/2==f(y)/2) cout<<"T"<<endl;
			else cout<<"F"<<endl;
		}
	}
	return 0; 
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值