两点间距离计算

给出下面的一个基类框架:

class Point_1D

{ protected:

    float x;//1D 点的x坐标

public:

    Point_1D(float p = 0.0);

    float distance(const Point_1D & p2);

}

以Point_1D为基类建立一个派生类Point_2D,增加一个保护数据成员:

    float y;//2D平面上点的y坐标

以Point_2D为直接基类再建立一个派生类Point_3D,增加一个保护数据成员:

    float z;//3D立体空间中点的z坐标

生成上述类并编写主函数,根据输入的点的基本信息,建立点对象,并能计算该点到原点的距离。

输入格式: 测试输入包含若干测试用例,每个测试用例占一行(点的类型(1表示1D点,2表示2D点,3表示3D点) 第一个点坐标信息(与点的类型相关) 第二个点坐标信息(与点的类型相关))。当读入0时输入结束,相应的结果不要输出。

输入样例:

1 -1 0

2 3 4 0 0

3 1 2 2 0 0 0

0

输出样例:

Distance from Point -1 to Point 0 is 1

Distance from Point(3,4) to Point(0,0) is 5

Distance from Point(3,3,3) to Point(0,0,0) is 3

 

 

 

#include<iostream>
#include<cmath>
using namespace std;
class Point_1D
{
protected:
    float x;//1D 点的x坐标
public:
    Point_1D(float p = 0.0):x(p)
    {
    	
	}
    float distance(const Point_1D & p2)
    {
    	if (p2.x>this->x)
    	return p2.x-this->x;
    	else return this->x-p2.x;
	}
};
class Point_2D:public Point_1D
{
	protected:
	float y;	
	public:
		Point_2D(float a,float b):Point_1D(a),y(b) 
		{
			
		}
		float distance(const Point_2D & p2)
		{
			Point_2D p(0.0,0.0);
			p.x=this->x-p2.x;
			p.y=this->y-p2.y;
			return sqrt((p.x*p.x)+(p.y*p.y));
		}
		
};
class Point_3D:public Point_2D
{
	protected:
		float z;
	public:
		Point_3D(float a,float b,float c):Point_2D(a,b),z(c)
		{
			
		}
		float distance(const Point_3D & p2)
			{
				Point_3D p(0.0,0.0,0.0);
				p.x=this->x-p2.x;
				p.y=this->y-p2.y;
				p.z=this->z-p2.z;
				return sqrt((p.x*p.x)+(p.y*p.y)+(p.z*p.z));
			}
		
		
};
int main()
{
	float a,b,c,d,e,f;
	int o;
	while(1)
	{
		cin>>o;
		if(o==1)
		{
			cin>>a;
			cin>>b;
			Point_1D a1(a);
			Point_1D a2(b);
			cout<<"Distance from Point "<<a<<" to Point "<<b<<" is "<<a2.distance(a1)<<endl;
		}
		if(o==2)
		{
			cin>>a>>b;
			cin>>c>>d;
			Point_2D a1(a,b);
			Point_2D a2(c,d);
			cout<<"Distance from Point "<<"("<<a<<','<<b<<")"<<" to Point "<<"("<<c<<','<<d<<")"<<" is "<<a2.distance(a1)<<endl;
		}
		if(o==3)
		{
			cin>>a>>b>>e;
			cin>>c>>d>>f;
			Point_3D a1(a,b,e);
			Point_3D a2(c,d,f);
			cout<<"Distance from Point "<<"("<<a<<','<<b<<','<<e<<")"<<" to Point "<<"("<<c<<','<<d<<','<<f<<")"<<" is "<<a2.distance(a1)<<endl;
		}
        if(o==0)
            break;
	}
	return 0;
 } 

答案正确,但格式有错误:5b85d0a69cc145778c1fd231146ed95c.png 

 

 

  • 6
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值