PTA:7-98 Number

解决一个编程挑战:给定一个整数数组,计算所有子序列的最大最小乘积。通过双重循环找到每个区间内最大值和最小值,得出最大乘积。
摘要由CSDN通过智能技术生成

作者 郭天宸

单位 山东大学(威海)

_October has a question:

You are given n integers a1,a2,…,an. Find the maximum value of max(al,al+1,…,ar)⋅min(al,al+1,…,ar)over all pairs (l,r) of integers for which 1≤l<r≤n.

INPUT:

The first line contains a single integer n(2≤n≤103) .

The second line contains n integers a1,a2,…,an(1≤ai≤106).

OUTPUT:

Please print a single integer — the maximum possible value of the product from the statement.

SAMPLE INPUT1:

3
2 4 3

SAMPLE OUTPUT1:

12

Note:

Let f(l,r)=max(al,al+1,…,ar)⋅min(al,al+1,…,ar).
In the first test case,
f(1,2)=max(a1,a2)⋅min(a1,a2)=max(2,4)⋅min(2,4)=4⋅2=8.
f(1,3)=max(a1,a2,a3)⋅min(a1,a2,a3)=max(2,4,3)⋅min(2,4,3)=4⋅2=8.
f(2,3)=max(a2,a3)⋅min(a2,a3)=max(4,3)⋅min(4,3)=4⋅3=12.
So the maximum is f(2,3)=12.

SAMPLE INPUT2:

4
3 2 3 1

SAMPLE OUTPUT2:

6
  • Advanced challenge :What if the maxinum of n is 3∗105 ?

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB

#include <stdio.h>

int main() {
    long long n, arr[1000];
    scanf("%lld", &n);
    // 初始化数组赋值
    for (int i = 0; i < n; ++i) {
        long long temp;
        scanf("%lld", &temp);
        arr[i] = temp;
    }

    long long now_max = 0;

    for (int i = 0; i < n - 1; ++i) {
        for (int j = i + 1; j < n; ++j) {
            // 求出区间最大最小值
            long long min = arr[i];
            long long max = arr[j];
            for (int k = i; k <= j; ++k) {
                if (min > arr[k]) {
                    min = arr[k];
                }
                if (max < arr[k]) {
                    max = arr[k];
                }
            }
            if (min * max > now_max) {
                now_max = min * max;
            }
        }
    }

    printf("%lld", now_max);

    return 0;
}

  • 25
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值