7-98 Number

7-98 Number

分数 5

全屏浏览题目

切换布局

作者 郭天宸

单位 山东大学(威海)

_October has a question:

You are given n integers a1,a2,…,an. Find the maximum value of max(al,al+1,…,ar)⋅min(al,al+1,…,ar)over all pairs (l,r) of integers for which 1≤l<r≤n.

INPUT:

The first line contains a single integer n(2≤n≤103) .

The second line contains n integers a1,a2,…,an(1≤ai≤106).

OUTPUT:

Please print a single integer — the maximum possible value of the product from the statement.

SAMPLE INPUT1:

3
2 4 3

SAMPLE OUTPUT1:

12

Note:

Let f(l,r)=max(al,al+1,…,ar)⋅min(al,al+1,…,ar).
In the first test case,
f(1,2)=max(a1,a2)⋅min(a1,a2)=max(2,4)⋅min(2,4)=4⋅2=8.
f(1,3)=max(a1,a2,a3)⋅min(a1,a2,a3)=max(2,4,3)⋅min(2,4,3)=4⋅2=8.
f(2,3)=max(a2,a3)⋅min(a2,a3)=max(4,3)⋅min(4,3)=4⋅3=12.
So the maximum is f(2,3)=12.

SAMPLE INPUT2:

4
3 2 3 1

SAMPLE OUTPUT2:

6

代码如下:

#include <stdio.h>
int main(){
    long n = 0;
    long arr[1000];
    long res = 0,num;
    scanf("%ld",&n);
    for(int i = 0; i< n;i++)
    {
        scanf("%ld",&arr[i]);
    }
    for( int i=0;i<n;i++)
    {
        for( int j=i+1;j<n;j++)
        {
            
            long min =arr[i];
            long max =arr[i];
            
            for(int k=i;k<=j;k++){
                if(arr[k] > max){
                    max = arr[k];
                }
                if(arr[k] < min){
                    min = arr[k];
                }
            }
            if(min * max > res){
                res = min*max;
            }
//             printf("%d %d %d",min,max,res);
        }
    }
    printf("%ld",res);
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小羊 : )

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值