PTA 7-98 Number

PTA 7-98 Number
_October has a question:

You are given n integers a1,a2,…,an. Find the maximum value of max(al,al+1,…,ar)⋅min(al,al+1,…,ar)over all pairs (l,r) of integers for which 1≤l<r≤n.

INPUT:
The first line contains a single integer n(2≤n≤10
3
) .

The second line contains n integers a1,a2,…,an(1≤ai≤10
6
).

OUTPUT:
Please print a single integer — the maximum possible value of the product from the statement.

SAMPLE INPUT1:
3
2 4 3
SAMPLE OUTPUT1:
12
Note:
Let f(l,r)=max(al,al+1,,ar)min(al,al+1,,ar).
In the first test case,
f(1,2)=max(a1,a2)min(a1,a2)=max(2,4)min(2,4)=42=8.
f(1,3)=max(a1,a2,a3)min(a1,a2,a3)=max(2,4,3)min(2,4,3)=42=8.
f(2,3)=max(a2,a3)min(a2,a3)=max(4,3)min(4,3)=43=12.
So the maximum is f(2,3)=12.
SAMPLE INPUT2:
4
3 2 3 1
SAMPLE OUTPUT2:
6

Advanced challenge :What if the maxinum of n is 3∗10
5
?

代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB

代码:

#include <stdio.h>

int main()
{
    long int n = 0, arr[1000], min = 0, max = 0, result = 0, num;
    scanf( "%ld" , &n );
    for( int i = 0; i < n; i++ )//循环输入到数组中
    {
        scanf( "%ld" , &arr[i] );
    }
    for( int i = 0; i < n; i++ )
    {
        for( int j = i + 1; j < n; j++ )
        {
            
            min = arr[i];//假设最小值是数组中的某一个
            max = arr[i];//假设最大值是数组中的某一个
            for( int k = i; k <= j; k++ )
            {
                if( arr[k] > max )//找出最大值
                {
                    max = arr[k];
                }
                if( arr[k] < min )//找出最小值
                {
                    min = arr[k];
                }
            }
            if( min * max > result )
            {
                result = min * max;//把最小值和最大值相乘
            }
        }
    }
    printf( "%ld", result );
    return 0;
}

解题思路
step 1:假设最大值和最小分别是数组中的一个值;
step 2:根据条件分别找出最大值和最小值;
step 3:最后结果取最大值和最小值的乘积。

归属知识点
循环结构,选择结构

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值