新学期开始啦,我们CPA是2019年6月成立的,创建时有20位元老。现在需要招新啦,每年新学期社团服务中心会组织百团大战。我们CPA迎来第一次招新,我们很期待迎来新成员。 每天都有元老去招新,每招到一个萌新,招新人会在纸上写一个大写字母。CPA共有竞赛部、宣传部、办公部、组织部四个部门。我们规定A代表竞赛部(Competition department),B代表宣传部(Propaganda Department)、C代表办公部(Office)、D组织部(Organization Department)。社团招新后需要统计每一个部门有多少人?
输入格式:
输入一行字符串,字符串长度不大于10000。
输出格式:
每输出一个部门换行。
输入样例:
AABBCCDD
输出样例:
Competition department 2 people!
Propaganda Department 2 people!
Office 2 people!
Organization Department 2 people!
解题思路:So eazy!!!!!!!!
#include<bits/stdc++.h>
using namespace std;
int main(){
string s;
getline(cin,s);
int a=0,b=0,c=0,d=0;
for(int i=0;i<s.size();i++){
if(s[i]=='A')a++;
if(s[i]=='B')b++;
if(s[i]=='C')c++;
if(s[i]=='D')d++;
}
cout<<"Competition department "<<a<<" people!"<<endl;
cout<<"Propaganda Department "<<b<<" people!"<<endl;
cout<<"Office "<<c<<" people!"<<endl;
cout<<"Organization Department "<<d<<" people!"<<endl;
return 0;
}