pat甲级1142 Maximal Clique

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<iostream>
#include<algorithm>
#include<cstring>
#include<set>
using namespace std;
const int N = 210;
int a[N];
int n, m;
bool g[N][N];
int k;
int b[N];
set<int>s;
int main() {
    cin >> n >> m;
    while (m--) {
        int l, r;
        cin >> l >> r;
        g[l][r] = g[r][l] = true;
    }
    cin >> k;
    while (k--) {
        int qq;
        cin >> qq;
        s.clear();
        memset(a, 0, sizeof a);
        for (int i = 1; i <= qq; i++) {
            cin >> a[i];
        }
        sort(a + 1, a + 1 + qq);
        bool is_clique = true;
        for (int i = 1; i < qq; i++) {
            for (int j = i + 1; j <= qq; j++) {
                if (!g[a[i]][a[j]]) is_clique = false;
            }
        }
        if (!is_clique) cout << "Not a Clique" << endl;
        else {
            bool flag = true;
            int pq = 0;
            int u = 0;
            memset(b, 0, sizeof b);
            for (int i = 1; i <= n; i++) {
                bool www = true;
                for (int j = 1; j <= qq; j++) {
                    if (i == a[j]) {
                        www = false;
                        break;
                    }
                    
                }
                if (www) b[++u] = i;
            }
          
            for (int i = 1; i <= u; i++) {
                bool aaa = true;
                for (int w = 1; w <= qq; w++) {
                   
                        if (!g[b[i]][a[w]]) {
                            aaa = false;
                            break;
                        }
                    
                }
                if (!aaa) pq++;
               
            }
            if (pq ==u) flag = false;
            if (!flag) cout << "Yes" << endl;
            else cout << "Not Maximal" << endl;
        }
    }
    return 0;
}

  • 6
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值