NOI / 1.7编程基础之字符串 27:单词翻转 分割,翻转,空格

本文介绍了如何使用C++编程语言正确处理输入的字符串,实现单词逐个反转并保持原单词间空格不变的功能,包括使用`getline`获取输入,`vector`存储单词,以及`reverse`函数进行单词反转。
摘要由CSDN通过智能技术生成

描述

输入一个句子(一行),将句子中的每一个单词翻转后输出。

输入

只有一行,为一个字符串,不超过500个字符。单词之间以空格隔开。

输出

翻转每一个单词后的字符串,单词之间的空格需与原文一致。

样例输入

hello world

样例输出

olleh dlrow

先来看错的(只能看一个空格,不能随心所欲的控制单词之间的空格)

#include <iostream>
#include <string>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;

int main() {
    string S;
    while(cin >> S) {
        reverse(S.begin(), S.end());
        cout << S <<" ";
    }
    return 0;
}

再看对的

#include <iostream>
#include <string>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
using namespace std;

int main() {
    string input;
    getline(cin, input);
    vector<string> words;
    size_t start = 0, end = input.find(' ');
    while (end != string::npos) {
        words.push_back(input.substr(start, end - start));
        start = end + 1;
        end = input.find(' ', start);
    }
    words.push_back(input.substr(start));

    for (string &word : words) {
        reverse(word.begin(), word.end());
    }
    for (size_t i = 0; i < words.size(); i++) {
        cout << words[i];
        if (i != words.size() - 1) {
            cout << " ";
        }
    }
    cout << endl;
    return 0;
}
#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
using namespace std;

int main() {
    string input;
    getline(cin, input);
    vector<string> words;
    size_t start = 0, end = input.find(' ');
    while (end != string::npos) {
        words.push_back(input.substr(start, end - start));
        start = end + 1;
        end = input.find(' ', start);
    }
    words.push_back(input.substr(start));

    for (auto &word : words) {
        reverse(word.begin(), word.end());
    }

    for (size_t i = 0; i < words.size(); ++i) {
        cout << words[i];
        if (i != words.size() - 1) {
            cout << " ";
        }
    }
    cout << endl;

    return 0;
}
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
    string s;
    int i, j, k=0;
    getline(cin, s);
    s = s + ' ';
    for (i=0; i<=s.size(); i++){
        if(s[i] == ' '){
            for (j=i-1; j>=k; j--) cout << s[j];
            cout << " ";
            k = i+1;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值