描述
输入一个字符串,输出该字符串是否回文。回文是指顺读和倒读都一样的字符串。
输入
输入为一行字符串(字符串中没有空白字符,字符串长度不超过100)。
输出
如果字符串是回文,输出yes;否则,输出no。
样例输入
abcdedcba
样例输出
yes
#include <iostream>
#include <string>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
using namespace std;
int main() {
string s;
cin>>s;
int flag=1;
int l=s.length();
for(int i=0; i<(l)/2; i++)
{
if(s[i]!=s[l-1-i])
{
flag=0;
break;
}
}
if(flag==1) cout<<"yes";
else cout<<"no";
return 0;
}