23:二维数组回形遍历

描述

给定一个row行col列的整数数组array,要求从array[0][0]元素开始,按回形从外向内顺时针顺序遍历整个数组。如图所示:

输入

输入的第一行上有两个整数,依次为row和col。
余下有row行,每行包含col个整数,构成一个二维整数数组。
(注:输入的row和col保证0 < row < 100, 0 < col < 100)

输出

按遍历顺序输出每个整数。每个整数占一行。

样例输入

4 4
1 2 3 4
12 13 14 5
11 16 15 6
10 9 8 7

样例输出

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
#include <iostream>
#include <vector>
using namespace std;

int dx[4] = {0, 1, 0, -1}; // 右、下、左、上
int dy[4] = {1, 0, -1, 0};

int main() {
    int row, col;
    cin >> row >> col;

    int array[row][col];
    for (int i = 0; i < row; i++) {
        for (int j = 0; j < col; j++) {
            cin >> array[i][j];
        }
    }

    int x = 0, y = 0; // 初始位置
    int dir = 0; // 初始方向
    for (int i = 0; i < row * col; i++) {
        cout << array[x][y] << endl;
        array[x][y] = -1; // 标记已经访问过

        int next_x = x + dx[dir];
        int next_y = y + dy[dir];
        if (next_x < 0 || next_x >= row || next_y < 0 || next_y >= col || array[next_x][next_y] == -1) {
            dir = (dir + 1) % 4; // 改变方向
            next_x = x + dx[dir];
            next_y = y + dy[dir];
        }
        x = next_x;
        y = next_y;
    }

    return 0;
}

  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值