POJ 1068 Parencodings <模拟>_tehran 2001 parencodings(1)

img
img

网上学习资料一大堆,但如果学到的知识不成体系,遇到问题时只是浅尝辄止,不再深入研究,那么很难做到真正的技术提升。

需要这份系统化的资料的朋友,可以添加戳这里获取

一个人可以走的很快,但一群人才能走的更远!不论你是正从事IT行业的老鸟或是对IT行业感兴趣的新人,都欢迎加入我们的的圈子(技术交流、学习资源、职场吐槽、大厂内推、面试辅导),让我们一起学习成长!

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001

题目大意:p代表,每一个右括号前有几个左括号,w代表每一个右括号和他前面的第几个括号匹配。

我们可以直接用数组来存,1代表左括号,0代表右括号,然后循环去找每一个右括号出现的位置前的左括号,如果这个左括号被使用过了

就标记为-1,下一个右括号匹配到这的时候步数加一即可

#include <iostream>
#include <cstring>
#include <stack>
#include <cstdio>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <set>
#include <map>

const double eps=1e-8;
const double PI=acos(-1.0);
using namespace std;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,a,a1=0;
        int s[50];//数字1代表左括号,0代表右括号;
        scanf("%d",&n);
        int j=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a);
            int tt=a-a1;
            while(tt--)
            {
                s[j++]=1;
            }
            a1=a;
            s[j++]=0;

        }

        int flag=0;
       /*  for(int i=0; i<=2*n-1; i++)
            cout<<s[i]<<" ";
         cout<<endl;*/
        for(int i=0; i<=2*n-1; i++)
        {
            if(s[i]==0)
            {
                int cou=1;
                for(int k=i-1; k>=0; k--)
                {
                    if(s[k]==0)continue;
                    if(s[k]==-1) cou++;
                    else if(s[k]==1)
                    {
                        if(!flag)
                        {
                            printf("%d",cou);
                            flag=1;
                        }
                        else
                            printf(" %d",cou);


![img](https://img-blog.csdnimg.cn/img_convert/1dba36aa7b19d7364da5a8b16a282a6e.png)
![img](https://img-blog.csdnimg.cn/img_convert/8b7dae49b50fc922537e346861fdbe22.png)

**既有适合小白学习的零基础资料,也有适合3年以上经验的小伙伴深入学习提升的进阶课程,涵盖了95%以上C C++开发知识点,真正体系化!**

**由于文件比较多,这里只是将部分目录截图出来,全套包含大厂面经、学习笔记、源码讲义、实战项目、大纲路线、讲解视频,并且后续会持续更新**

**[如果你需要这些资料,可以戳这里获取](https://bbs.csdn.net/topics/618668825)**

**由于文件比较多,这里只是将部分目录截图出来,全套包含大厂面经、学习笔记、源码讲义、实战项目、大纲路线、讲解视频,并且后续会持续更新**

**[如果你需要这些资料,可以戳这里获取](https://bbs.csdn.net/topics/618668825)**

  • 3
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值