HDU 1047 Integer Inquiry

8 篇文章 0 订阅


Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12591    Accepted Submission(s): 3187


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
 

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
 

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Sample Input
      
      
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
 

Sample Output
370370367037037036703703703670
结题报告:高精度加法
 
     
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int main(int argc, char const *argv[])
{
    const int maxlen = 110;
    int CASE;
    char str[maxlen];
    int sum[maxlen];
    scanf("%d",&CASE);
    while(CASE--)
    {
        memset(sum,0,sizeof(sum));
        while(scanf("%s",str),str[1]!='\0'||str[0]!='0')
        {
            int len = strlen(str);
            int i;
            for(i = 1;i <= len;i++)
            {
                sum[maxlen-i] = sum[maxlen-i] + str[len - i]-'0';
                if (sum[maxlen-i] > 9)
                 {
                     sum[maxlen-i-1]++;
                     sum[maxlen-i] %= 10;
                 } 
            }
        // for (i = 0; i < maxlen; ++i)
        //     {
        //         if (sum[i])
        //         {
        //             break;
        //         }
        //     }
        // for (;i < maxlen-1; ++i)
        //     {
        //         printf("%d",sum[i]);
        //     }
        //     printf("%d\n",sum[maxlen-1]);
        
        }
        int i;
        for (i = 0; i < maxlen; ++i)
            {
                if (sum[i])
                {
                    break;
                }
            }
        for (;i < maxlen-1; ++i)
            {
                printf("%d",sum[i]);
            }
            printf("%d\n",sum[maxlen-1]);
        if (CASE)
        {
            putchar('\n');
        }

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值