HDU 4597 Play Game

135 篇文章 0 订阅
32 篇文章 0 订阅
Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?
 

Input

The first line contains an integer T (T≤100), indicating the number of cases.
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤b i≤10000).
 

Output

For each case, output an integer, indicating the most score Alice can get.
 

Sample Input

    
    
2 1 23 53 3 10 100 20 2 4 3
 

Sample Output

    
    
53 105
#include <stdio.h>
#include <string.h>
#include <algorithm>  
using namespace std;

#define MAXN 22
int dp[MAXN][MAXN][MAXN][MAXN],aa[MAXN],bb[MAXN];

int dfs(int a,int b,int c,int d,int sum)
{
    if(dp[a][b][c][d]) return dp[a][b][c][d];
    int temp=0;
    
    if(a<=b)
    {
        temp=max(temp,sum-dfs(a+1,b,c,d,sum-aa[a]));
        temp=max(temp,sum-dfs(a,b-1,c,d,sum-aa[b]));
    }
    if(c<=d)
    {
        temp=max(temp,sum-dfs(a,b,c+1,d,sum-bb[c]));
        temp=max(temp,sum-dfs(a,b,c,d-1,sum-bb[d]));
    }
    dp[a][b][c][d]=temp;
    return dp[a][b][c][d];
}

int main()
{
    int t,n,i,sum;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&aa[i]);
            sum+=aa[i];
        }
        for(i=1;i<=n;i++)
        {
            scanf("%d",&bb[i]);
            sum+=bb[i];
        }
        memset(dp,0,sizeof dp);
        printf("%d\n",dfs(1,n,1,n,sum));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值